Streaming live at 10am (PST)

Some help with an autoplay video


#1

I'm building a page on my site where I want a small video to autoplay over an image of a macbook as pictured below. I was able to get pretty far, but cannot figure out a way to make the video play the appropriate size within it's "background video" box. When I open it in chrome and mess around by adding a max-height of 100% to ".w-background-video>video", it resolves the issue (shown in the second screenshot below). How can I make this attribute change to the background video within Webflow?


Here is my public link: http://danny-weilandt.webflow.io/rivian-automotive
Here is my read only link: https://preview.webflow.com/preview/danny-weilandt?preview=e4945f6f847c5bb7f6c5d6da4f226153 (the page in question is linked from the "Rivian Automotive" slide on the home page)


#2

You can add the code the head section of your page (page settings) to correct this on publish (with style tags around it):

.w-background-video>video {
max-height: 100% !important;
}


#3

Hi, @Joe_Hoff,

Thanks for you response! Worked like a charm. Before I wasn't adding the style tags.

Thanks!


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.