Streaming live at 10am (PST)

Space between footer and end of page


#1

Hi guys,

When I test my page on the toggle preview, I see a perfectly formatted website as I want it, with the footer bar stuck to the bottom of the page.

When I publish this, I get a gap. Not too sure as to what I have done or how I can get this gap to go. I’ve tried using fixed, but I do not want the footer bar to scroll with me. I just want it to stay at the very bottom of the page.

Hopefully this is an easy fix because I have done something silly, thanks!


Here is my public share link: LINK
(Live site link)


#2

Assuming you’ve made sure there are no Margins around the bottom part, perhaps something along the lines of giving the Section above it a Height of 100vh might help? Or make it display Flex and set the children to fill empty space maybe… Not sure if those will help, but just a couple random ideas… Let me know if it works!


#3

Its the webflow button in the right corner. That makes it easy to access the EDITOR for the client. Its irritating and no way to turn it of. But then again, its only you and your client that get that…


#4

@Waldo These didnt see to do the trick and I dont think it’s the webflow button as on some pages it’s perfectly fine.


#5

@adedamolisher it looks like the issue is stemming from a few pieces:

  1. You have a min-height set on the body of 1000px:
  2. Your content is not large enough to always cover the full page height which can cause that odd piece of the page to appear

A fix you could apply is setting your “section” to a min-height of 100vh:

Here’s a guide on how to use VH and VW units in a Webflow site.


#6

Hi @Waldo,

Changed it to Vh as you recommended and got a bigger gap, but I still have the space. Could it be the webflow logo causing the issue?

And the Vh is 100

24


#7

In this case @adedamolisher that is actually the Webflow Editor causing that bottom padding to show up:

Just visit the site in incognito mode and you shouldn’t see that around but it’s cached locally on a machine where you have accessed the Editor for that site.


#8

@krubens @Waldo seems the webflow editor was actually causing the problem. :sweat_smile:

Everything seems to be okay now


#9

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.