Streaming live at 10am (PST)

Spaces in rich text removed when copy and pasting

Hello.

When I try to copy text from a Word document into the CMS in a rich text collection field:

A lot of the words get thrown together/the spaces get removed.

It’s not in English, but here is how the sentence is written in Word:
image

and when pasted into Webflow:
image

You see the first word the space goes missing? So instead of 2 words it becomes 1. This happens randomly throughout a text…

Pls help.

Also, its very annoying that it gets underlined red just cause its not in English.
How to fix this/change this as well?

The solution is to paste plain text, then format. Sometimes it is beneficial to copy then paste to a plain text editor, then you can copy and paste to the RTF. The forum is chock full with similar posts. You can also look at using a modifier to paste.

To ensure that no unwanted formatting is pasted, use the keyboard shortcut to paste unformatted text (CMS+SHIFT+V on mac — CTRL+SHIFT+V on windows). This will strip the text of all formatting including bold and italics. Be careful though, it also removes links.

More info about working with the Rich Text widget is available in the university.

Thanks. But why isnt it working out of the box? Webflow should be able to handle simple copy paste, no?

Also do you know how to remove red underlines?

That is your browser spell checking the words. You can turn off browse features in your browser settings.

1 Like