Streaming live at 10am (PST)

Spooky Form Behaviour

Our site is up and working well https://www.staffordcreative.com/ except for the form. It’s hosted on Webflow.

It’s a simple form, but after lots of testing the email notice it should send is behaving very oddly. Here’s the scoop when we’ve tested with 3 different email addresses:
Email #1 - always works
Email #2 - works sometimes
Email #3 - works sometimes

We want them to go to the two that work sometimes (of course). We’ve messed with spam filters etc and it just seems very random. My next step is to work with my email host more intentl, but wanted to see if anyone has a clue to this.

Loving Webflow so far! (I’m a Muse Refugee)
Thank you!

Okay, I’m responding to my own post! I may have figured this out. You have to set mailjet.com as safe/whitelisted since that is who webflow uses to process and send the email.

@Sid are you using a personal address? I can’t quite believe this isn’t mentioned somewhere yet but you need to use an address like yourname@yourwebsite.com. If you use something like contact@ or info@, it messes with the filters. There’s no way around that at the moment. They can unblock for a while but keep getting black-listed, it sounds like that could be the issue here :).

Hi Sarah,
Good thinking! But Yep, I’m using personal addresses! I think whitelisting mailjet.com worked so far!

Nope. Neither worked. Random emails are getting though!

@Sid :thinking: i’d try and reach out to support, see if they can see what’s going on :slight_smile: