Streaming live at 10am (PST)

SSL certificate expired after connecting my domain

Hello,
I’m facing an issue just after connecting my domain to webflow.
The connection works but the navigators (Chrome, Safari, Firefox) don’t find the security certificate so the website looks suspicious now.
Could you please help me?


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @Jessypage thank you so much for posting this!

Can you please share a link to your custom domain? It’s possible that the DNS records are still propagating globally. We issue SSL certificates automatically for all Webflow hosted sites configured with these instructions.

A quick way to check the status is to look up your A Records on the root domain and the CNAME record on the “www” or other subdomains here: https://www.whatsmydns.net/

You should see the following A Records:

  • 75.2.70.75
  • 99.83.190.102

As well as the following CNAME record:

Any additional A records on the root domain can cause issues.

Please let me know if this is helpful or if you have any additional questions! You can contact us directly and we can look into your site as well.

Hello Waldo, thank you for your answer.
The domain is: melstalk.fr
In my parameters, Webflow doesn’t ask me to input A records like: 75.2.70.75 & * 99.83.190.102
but 23.235.33.229 & 104.156.81.229 instead. Why’s that?

How long have you had those DNS? Webflow had sent me a few emails, asking me to update the DNS. While reading your initial post, I was thinking that it’s your DNS too. Long story short. I’d put the newer DNS into my web host and all is fine. Try that and let us know if it resolved your issue?

Only one day. I put them on yesterday…

Hi @Jessypage thank you so much for letting me know! Those are the DNS records if SSL is turned off in your site settings.

Can you please activate the SSL setting, and then follow the DNS configuration settings with your custom domains, please?

Please note that it can take your DNS records up to 48 hours to propagate globally.

Thank you for your help! Problem solved now! I’m not good at waiting :sweat_smile:

1 Like