Streaming live at 10am (PST)

SSL selected, but live site "not secure"

I finally posted my site and went live via Webflow hosting. In advanced hosting and advanced publishing options I have the “enable SSL” slider to the right, and it says “on”. None the less my site is “not secure” and you get a warning not to enter the site due to this. Am I missing something, or does this take a while to go into effect?

https://preview.webflow.com/preview/louiss-radical-project-d73ee4?utm_medium=preview_link&utm_source=dashboard&utm_content=louiss-radical-project-d73ee4&preview=19781ffc28af7b4eb9535ec278e8eb0a&mode=preview

Does your domain provider allow SSL?

Good question. I don’t know, The provider is Inexpensivedomains.com. Come to think of it it worked previously with the same domain provider but I had a different (private host/server). They were able to setup the SSL. I only have this problem now that I changed over to the webflow hosting today.

Even if it is standard, some dodgy providers do not follow…
Their own domain is not secure :man_facepalming:

Got it. Well, it was secure yesterday when the site was live running from another server, so I think the domain provider isn’t the issue. It only became “not secure” after my switching today to the webflow hosting/server. So I imagine something is going on there or I didn’t fully set something up correctly. I just don’t know what to look at other than making sure the SSL is checked on in the hosting section.

Anyone on this? I currently have a business website that is inoperable due to this issue which of course is less than optimal.

For anyone who comes across this with a similar problem. The issue was that I set the SSL to “on” after I entered the information (the two A value numbers and the one Cname) to the DNS server. Apparently selecting the “enable SSL” changed those values. Once I went back into Webflow and got the new values, and entered them into the DNS I was good to go.

1 Like

Thank you for sharing the solution :webflow_heart: