Streaming live at 10am (PST)

Sticky position working in preview but not when published

HI there! i have a problem with sticky position. It is working in preview mode but not when i publish my website.

https://preview.webflow.com/preview/sellevate-9e0455?utm_medium=preview_link&utm_source=designer&utm_content=sellevate-9e0455&preview=1c4a2df7d00fef8f44935f811513ca04&pageId=5e39540492a3a501ac8541c7&mode=preview


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey @Roel_Dekkers, can you also share a published link? I can see your preview working, but I’m unable to figure out the error without seeing it in action.

Here you have the published link; https://www.sellevate.nl/kenniscentrum

Hey @Roel_Dekkers, I found out the problem:

You cannot set position sticky when you have overflow: hidden/scroll/overlay on any parent/grand-parent. If you just disable this overflow, it’ll work as expected.

The reason it is working in preview mode is because this properties were set in custom code and are just applied when you publish.

I couldn’t find the code inside the Webflow designer itself neither the custom code in Home Settings. So I presume it’s in the Custom Code for all pages.

Just find the overflow-x: hidden; and overflow-y: overlay; and delete it.

i didnt know to fix it, recently i also faced the same issue i guess you missed some paramters call.

[Kitchen Exhaust Duct Installation Los Angeles](https://kitchen.services/kitchen-hood-installation/)

Thanks for your clear explanation!

greetings,

Roel