Streaming live at 10am (PST)

Stop contact form disappearing after successful submission

There is a post a few years back on this: Disappearing Form on submission

That suggested adding a code along the lines of:

.my-form {display:block !important;}

However, we are still quite new to coding, Webflow and creating a site in general. We know we should be adding the CSS custom code in the page setting, and based on the post, we know ‘my-form’ needs to be changed to whatever ID we use for the form.

Something is missing as the code did not work for us. We don’t know what though.

Some help would be appreciated! Thank you :slight_smile:


Here is my site Read-Only: LINK
([how to share your site Read-Only link][2])

The “.”(dot) in there is a class selector, not an id selector (which is “#”).

That means that you need to either use “.+class-of-the-form” or “#+id-of-the-form”

Hi! Thanks for your input. We tried: #Contact-form-fields {display:block !important;}

Didn’t work.

We then tried: .Contact-form {display:block !important;}

Also didn’t work. Still don’t know why it’s not working :confused:

Oh, there are a couple of things there that are causing it to not work properly:

Here’s what you need to do:

Replace all the code you have in the page settings with this:

<style>
#Contact-form-fields{
    display: block !important;
}
</style>

This should take care of it

Works!!! :slight_smile: Thanks so much!!!

1 Like