Streaming live at 10am (PST)

Strange and frustrating behaviour

HI to all of you here,
in need of help before we go totally crazy:) not kidding. we work and work everyday on our project here, safe it, publish it, everything looks fine, we go to bed, start again next morning and our project doesn’t look the same anymore. Here’s our project read only link:
https://preview.webflow.com/preview/sis-ea61d3?utm_medium=preview_link&utm_source=designer&utm_content=sis-ea61d3&preview=52c47048ffc3cd6c9771fe6ffe6d7026&pageId=5e155c1b17a0cfa804d6b0f2&mode=preview

Or we are working on it and we can’t safe or publish in between. Right now we’ve redone our homepage for the, I don’t know anymore, for which number of time we had to redo it again and again. We are new to webflow, we checked everything on our end and we can’t find something causing this problem on our end. Please @webflow can you have a look and help us to fix this, we are due to finish our project soon but we don’t want to give it to our client as long as we don’t know what 's going on here.

I looked up the forum here and saw we are not the only ones having such problems. Maybe @adiggy you have an Idea whats going on in our project, I saw you had similar difficulties a couple of months ago.

Thanks, Christine


Here is my site Read-Only: https://preview.webflow.com/preview/sis-ea61d3?utm_medium=preview_link&utm_source=designer&utm_content=sis-ea61d3&preview=52c47048ffc3cd6c9771fe6ffe6d7026&pageId=5e155c1b17a0cfa804d6b0f2&mode=preview