Streaming live at 10am (PST)

Strange delay when scrolling to internal anchor link?

Hi all,

I have an issue and I can’t seem to pin it down, hoping someone here can help.

When I click a link to an anchor tag that is further down the page, the page seems to wait for about a whole second before initiating the scroll. This delay isn’t present on the editor during preview mode, however it is present on the published page.

I’ve cloned the site so that I could systematically remove things that might be causing this delay. I’ve removed all custom js and css, and removed almost all the elements from the page, and even all the other pages, yet the delay still exists on the published site.

I have to mention that the delay ‘seems’ minor with a page as simple as this, but the way the page was designed (with lots of interactions and 3d transforms) makes this small delay feel huge, so I’m really keen to find a solution.

Does anyone have any ideas for removing this delay?

Thanks in advance!

Jamie


Here is my site Read-Only: https://preview.webflow.com/preview/splash-digital-c780554a3f69ac13bf4a9f6b?utm_medium=preview_link&utm_source=dashboard&utm_content=splash-digital-c780554a3f69ac13bf4a9f6b&preview=ab0f86e5894774be22a0a068d6844749&mode=preview

And the published URL (with delay) https://splash-digital-c780554a3f69ac13bf4a9f6b.webflow.io/

Hi all, just a quick bump here on this post of mine as I’m still stuck here and would grately appreciate any suggestions! Huge thanks in advance!

I do not get the feeling of a delay. Looks normal to me. Do you jave a link to the published site?

Thanks for looking into this!

Apologies, I hadn’t realised that you couldn’t access the publisehd version from the read-only url. Here is the link to the publisehd site: https://splash-digital-c780554a3f69ac13bf4a9f6b.webflow.io

Ok now i se, Strange. Will se if i cand find anything

Thanks…

Ha, I guess it took me a couple of week away to come back at it with fresh eyes. I found the problem.

I had a little custom css in the page settings (forgot to look there before!)

The culprit was:

html {
scroll-behavior: smooth;
}

Strange that this caused a delay… but, I’m glad I found it.

Thanks again for taking a look all the same! In some way I think you helped me solve the problem!

1 Like