Streaming live at 10am (PST)

Style works properly in Webflow preview and on local drive, but does not render properly when uploaded onto server

Im experiencing some issues with my styles when exported and uploaded onto my server (liquidweb).

The button style renders and reacts just as I have asked it too within the previewer:
https://preview.webflow.com/preview/margos-initial-project-24aefb?utm_medium=preview_link&utm_source=designer&utm_content=margos-initial-project-24aefb&preview=8388ca069399ccfeebb84275a77e7f58&mode=preview

I’ve exported the code and reviewed it on my local drive, works beautifully. But once I upload the code onto my server Im experiencing this:

Currently my client really really wants that button to stick to the top of the browser and float like it shows in the webflow preview.

Any ideas why this is happening?


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

I’m seeing the same effect on the live website posted above - the orange “Sign Up” button sticks once it touches the top edge of the browser and follows me down the page. I’m using the newest Chrome browser on Windows 10 if that information helps.

1 Like

Thats really interesting. I contacted my server help desk and they recommended that I cleared my router cache as well as my browser cache, then test it on several IP addresses, which I did, and still was seeing different results

What browser/operating system are you working on? Sticky is pretty widely supported (unless you’re using IE 11, Opera Mini, or Baidu Browser) so I’m not sure what the issue could be.

Do you see any errors in your console when viewing the website?

I just updated my Chrome browser to 10 with the same issues. This is the error im getting in the inspect console. I have no clue what this means:

Grammarly.js:2 [DEFAULT]: WARN : Using DEFAULT root logger
t.printToConsole @ Grammarly.js:2

Grammarly.js:2 [WARNING] Using default timeseries implementation.
e.getRootMetric @ Grammarly.js:2

Can you try visiting the site in incognito (with all browser extensions disabled)? I’m not seeing that error on my end so I’m guessing there’s a conflicting Grammarly extension getting in the way.

1 Like

OKAY that made a difference! Now its working fine. How do I fix it?

I’m not sure I can help much with that as I’m not sure of the exact setup you have on your server, or what additional scripts you may have that are conflicting with the Grammarly extension.

There seem to be a handful of threads I found after a quick search for “grammarly default root logger” (which is the first issue you included from your console) so I’d poke around the results to see if anything looks familiar. Keep in mind that the results will reference a number of other platforms and technologies, but it may lead you to a solution in your case.

1 Like