Streaming live at 10am (PST)

Submit Sitemap to Google Webmasters Tools


#1

Webflow gives me a Site Map URL to paste in Google Webmasters Tools

but then on GWT I just have my own domain

Finally I add sitemap.xml next to my domain and obviously I get an error message

Which is the trick?

BTW, is it any tutorial explaining the necessary steps to connect the site with Google Webmaster Tools just like the tutorial about Connecting the Custom Domain? I mean some more explanation about sitemaps, robots, keywords,... I feel just pressing the 'Publish' button is not enough and there is a mountain of work once the web design is finished. In my opinion, Webflow is the best tool on earth to design a website whether you are professional web designer or you are completely new in the field. However, once you are done, what people needs is to be found in Google and for those like me without any web knowledge, it is a bit painful to set everything up. I understand this is not Webflow's responsibility but it would be really helpful. Thanks!


#2

Has this been resolved? I have the same issue. What is the solution Webflow gave you?


#3

Same issue here too. Have you find a solution?


#4

Not yet. I'm still working on the contents so I postponed this issue for the future when the site is completely finished


#5

Hello - Need help with this as well. How do I put sitemap.xml on my own domain name? Any help will be greatly appreciated. Do I need to upload a file manually?


#6

Hi there,

Not sure if this helps, and it's not immediately evident but I was having this problem till a round of updates a while back.

If you publish to custom domain/s, (1) you may need to go back in and repress "generate sitemap" once the custom domains are successfully set up. I noticed this changes the preview of the sitemap.xml in the Webflow screen to the custom domain name (particularly the http://customdomain..... (Note: (2) you may have to republish).

Given that Webflow has the great ability to generate the .webflow.io sites as well, the "use this URL" (the .webflow.io) one as per the backend of your Webflow site can be a little misleading as, if like me, your Google Webmaster Tools is set up through the pure domain so that it works, not the .webflow.io.

But, I jump over to (4) Google Webmaster Tools, submit a new site map as per the set up as the pure custom domain (5) using simply "/sitemap.xml" at the end of it and it works for me both in testing and submitting.

Hopefully haven't made it too confusing, but long story short: regenerate sitemap ( should show custom domain), republish, submit sitemap to Google WT by adding "sitemap.xml" to the end and then test and hopefully works also.

Let me know,
Regards,
Dom


#7