Streaming live at 10am (PST)

Symbols and Menu

Hello,

I have two questions.

  1. Symbol: I created a symbol of my Nav bar and added an animation when you scroll it disappears and reappears. I saved it as a symbol then when I place it on another page the animation doesn’t carry over to each new page. Now I am forced to do the animation one by one. Why?

  2. Nav/menu links: after I visit a page it stays solid blue (via img attached). I went through everything and I have no color blue present in any of my settings.

Thank you


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @Itsaprolificworld,

Have you fixed these 2 issues? If not shoot a response and I’ll help ya.

No, I have not fixed these issues.

If you post your read only link, I can help fix these today. See ya.

@garymichael1313 hey here’s the preview link

https://preview.webflow.com/preview/itsaprolificworld?utm_medium=preview_link&utm_source=dashboard&utm_content=itsaprolificworld&preview=e692f0fb48ad9413db5956c437dc18fb&mode=preview

That read only link is incorrect. Can you post it again.

@garymichael1313 hey try this one by sure why it didn’t work.

https://preview.webflow.com/preview/itsaprolificworld?utm_medium=preview_link&utm_source=dashboard&utm_content=itsaprolificworld&preview=b130af6d58fe6ce2e127c891f8fc4e37&mode=preview

Thanks,

  1. For “ANY” page link (not others, only page nav type links). There are going to be 3 parts to set your CSS. This goes for any link that goes to a page. It’s good practice to check these.

A - Normal
B - Visited
C - Current

It took me a while to discover this. If you see from the screenshot. The page you’re on is the “current” link:

current-link-webflow

To fix this, you MUST click in the color box before it takes effect. You cannot click and swatch or type in the value - it sometimes doesn’t hold - and other times it does. Best to click and add the value. While it says “current” next to the class.

  1. Yep, when you copy to another page and it’s not a specific class, but just an element. The element will get a name, like Div 1 turns into Div 1 copy. If there’s a conflict. Understandable to prevent overwriting. But IX2 will not know that, instead the interaction will show the “yellow exclamation”.

selected%20element%20webflow

Best practice is to use “Class, All elements with this class” on each element in the list, whenever you can. It’s not always possible, but it should be first option. Try to avoid - using ‘Selected Element’.

Oh FYI, Almost always add on the Interaction at the very bottom, Use Class, as well. On page interactions it doesn’t give the option but element triggers it will.

See ya, have fun :slight_smile:

@garymichael1313 great thank you so much for you’re help I was so lost. I will give this a try tomorrow and see if I can get it working properly.

No problem. See ya later :slight_smile:

@garymichael1313 Thank you so much for your help. The Current state was probably the most difficult because it’s not a “standard” state in the drop down like hover and etc. None the less I got I figured out. Thank you again.