Streaming live at 10am (PST)

Tabs added unwanted spacing after exporting c


#1

Hi guys,

After export and uploading the source code there´re spacing between the tabs although i gave each tab just 25% width. I´ve this problem every time i use percentage values at the tabs. While the upload at the test link .webflow doesn’t show such a problem.

Does anybody know whats exactly happened there? Is there a solution for that?

For now i solved it, while i changed the value in the code from 25% to 24.7%. All tabs are now in line but it looks not so pretty with this unwanted spacing. (See 2nd screenshot)

Thanks in advance blush



#2

I don't have an answer, but wanted to mention this happened to me too.

My tabs looked fine in the designer and preview, but when opening locally via the export, I got extra space.

I ended up adding an override in my project's Sass to tend to it. Fortunately the little less percentage didn't impact my design adversely, like it does yours.

Bookmarking this to see what WF may have to add.


#3

To improve it a little more i set the margin to -2px. Now all tabs are again in line without this margin but still not it should be. Now i got a tiny margin on the outer right side of the tab panel. So i would be happy about better ideas to get rid of this bug.


#4

This only happens on export ?... with a specific browsers or all browsers


#5

Yes, this only happens on export the code and i tested it at Chrome and Safari latest version. Publishing on the free .webflow server doesn´t show this bug.


#6

Had the same issue especially with Firefox. What I did is I made my tabs display: inline-block; width: 22%; margin-left: 1%; margin-right: 1%; and I made text-align: center; for parent container. Worked fine ;)


#7

Do you have a screenshot of this? I guess you aimed a margin (Space) between each tab. In my design i wanted to have the tabs without spacing. But generally spoken, i´m a little bit surprised about this weird bug. And i could´nt find any clue in the code to this.


#8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.


#9