Streaming live at 10am (PST)

Tabs Component not working

Hey there,

I’m experiencing issues with the tabs component, trying to navigate to the next tab, forwards me to the top of the page /#w-tabs-0-data-w-pane-1

https://jenss-awesome-project-3581f7.webflow.io/
https://preview.webflow.com/preview/jenss-awesome-project-3581f7?utm_medium=preview_link&utm_source=designer&utm_content=jenss-awesome-project-3581f7&preview=e0d5e047af5ec86cafc31917f1c09f25&mode=preview

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

2 Likes

Having the exact same issue. It seems to be because of the addition of /#w-tabs-0-data-w-pane. Once a tab is clicked anywhere on the page, the page moves up to the top (and in some cases down to the bottom). Very frustrating, it wasn’t doing this yesterday.

+1 — tabs have been working for weeks while working on a project published to domain.webflow.io, but published today to custom domain and experiencing the exact same /#w-tabs-0-data-w-pane issue and scrolling to top of page

1 Like

+1 I thought I was going crazy but it’s not just me experiencing this afterall!

1 Like

+++ damn, i was giong crazy too ( #w-tabs-0-data-w-pane-1e)…

1 Like

Yeah, I stressed for 3 hours to find out what the problem was with my site.
Now it works again but there is a blue border around the tabs.

the blue border around your tabs is native browser functionality and needed for accessibility options like screen readers, and keyboard only navigation. you can overwrite this style but it’s definitely not suggested without implementing a workaround in order to stay ADA compliant. you’d be looking for the ‘outline’ css property on said element — https://codepen.io/anon/pen/axBjdm

So - what’s the solution here?

My tabs are still scrolling me up to the top of the page.

Have you tried republishing your site? I think Webflow deployed a fix. Unless it’s broken again since which is possible.

Jason is correct, we fixed this pretty quickly after the issues surfaced in March. If it doesn’t fix on republish, please contact support@webflow.com. Thanks, and sorry for the inconvenience!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.