Streaming live at 10am (PST)

The designer becomes so slow and laggy that it's unusable

The designer’s stability seems to have been going downhill for some time now. I remember when I first started using Webflow years ago there was never an issue, but unfortunately now days things are so bad, so much of the time that I often have to give up working in Webflow all together. It becomes incredibly laggy and slow to respond.

I can’t pinpoint exactly what causes this, but it seems to be any time that any of the following factors are present in a site:

  • I’m trying to edit a CMS item or collection when there are a large number of CMS items or collections on the site.
  • I’m trying to edit a page that has a large number of CMS items on it.
  • I’m trying to edit a page that has more than about 5 images on it.
  • I work too fast and end up clicking things faster than the designer can handle, then it throws a wobbly.
  • And fairly often, for no particular reason at all.

Quite frankly I’m at my wit’s end. I’ve followed all the regular advice like clearly the cache, trying with all extensions disabled etc, but the underlying problem still hasn’t been addressed. I’ve been putting up with this for at least 1 year that I can remember. This topic comes up frequently and is a major problem for many people. Yet it hasn’t been addressed formally by Webflow (correct me if I’m wrong, but I can’t find anything).

Things have gotten so bad that I can no longer recommend building and serious websites in Webflow - it’s just too buggy. Simple landing pages sure, but anything beyond that has become a nightmare to work on. This makes me sad as I had been a huge Webflow proponent and have brought partners and clients to the platform since I joined.

I’m pretty sure this isn’t related to PC performance either, I’m running Google Chrome on Windows 10 with an i7-3930K, 32Gb of memory and a GTX 1070.

Webflow, can you please do something? I want to keep using Webflow but this is making it almost impossible.

7 Likes

Try voicing that issue in the ongoing https://forum.webflow.com/t/webflowchat - they are asking about least favorite part of the web design process :slight_smile:

Yes, we want to hear about your least favorite part about the web design process in that thread. Feel free to share.

@Ozone my machine specs are in the original post. I would have thought this was totally overkill for running Chrome. This is an older i7 but still more than up to the task of running a workstation.

You are right. That should do just fine. Interesting.

@jasondark I come from a graphic design background, so I don’t claim to be fully familiar with all the processes attached to perhaps solved Webflow errors with CSS code. I have also managed to implement code successfully from forums and other sources.

As I’ve been using the Adobe Creative Suite for around 16 years now, I have always relied on its reliability and following processes to achieve an outcome, from complex book layouts to interactive pdfs, it really forms the basis of all creative creation for me. I decided I needed to adapt as I was doing much more visual design and interfaces. This journey started with Sketch and then led to Webflow.

I accepted that alot of my experience in Webflow was going to be about time, immersing myself to learn little by little, like the first clipping mask I did in Photoshop 16 years ago. I quickly realised the Webflow University and guided videos are really only dipping the toes in the water. They did not unpack the complexity required to intergate large CMS with animation triggers successfully.

I have tried to implement a TABS module recently and the whole system is not responding to my commands, labels are not changing and everything is erratic. This has seen me re-create delete hours of work in the hope I will unlock the perfect amount of steps, before it all collapses. The lag is extreme.

Yesterday I was constantly sending error reports, refreshing the window, items just disappearing for no reason, elements that won’t Fix. Animations that have been applied to all Classes no responding. Checking for clashes and deleting and still no change.

I’m sure there is a percentage of bad practice on my behalf, but honestly when you follow STEP-BY-STEP and then it all comes undone as you build more complex content. The interface is today, its almost unworkable! Maybe web design of this nature is more complex than I realise or I don’t have the right tools. But honestly, the reliability is not there right now. Maybe some restrictions are required to be stated?

I’m running
iMac (27-inch, Late 2013)
Processor 3.2 GHz Quad-Core Intel Core i5
32 GB 1600 MHz DDR3 (Everything on the cloud)

Google Chrome
Version 80.0.3987.162 (Official Build) (64-bit

1 Like

I have the same issue with the Designer being slow, especially in the CMS Collections. When I try to create a new collection and I have to scroll down into the select options of a reference field, it’s really slow.

It makes my computer slow, typing is slow and actually everything becomes slow.
I’m using:

Processor: Intel Core i7-6700 CPU 4.00ghz
RAM: 16 GB
Windows 10 64

Chrome
Versie 81.0.4044.92 (Officiële build) (64-bits)

Same here. Performance has been spotty to say the least.

CMS collections - extremely slow after reaching a few 1000 items (even though I’m on the 10k plan)
Editor - same as above. Almost unusable in certain circumstances. Have to type in stuff outside of the editor and paste it in, otherwise it takes up to a second per letter(!!!).
Designer - usually alright, though certainly worse performance than a few months. It’s been crashing randomly for me the last few months and I have to refresh the window. Tons of bugs have popped up too, and lately I can’t seem to save stuff without some issue.

Hi @MGAVIOLI66, @ElviraNL, & @Fonsume,

We are working on collecting data for performance-related issues with the CMS. Can you send me the share links of each of your projects that you are seeing this slowness happening on?

Best Regards,
~ Brandon

https://preview.webflow.com/preview/portfolioelvira?utm_medium=preview_link&utm_source=designer&utm_content=portfolioelvira&preview=ac7087d91e80750629fc93bb40306b22&mode=preview

1 Like

Hi Brandon, I am experiencing this problem too - https://preview.webflow.com/preview/nambee-1960?utm_medium=preview_link&utm_source=dashboard&utm_content=nambee-1960&preview=ee66cf8aa32d3b398a8bf16d320deb75&mode=preview

Very grateful for any help as it’s currently so slow I can’t do anything! Thank you

1 Like

I am also having the same issue. It would be much better to add a search feature to the field as well.

I’m also finding a long delay when i press anything in designer resently

I’m also experiencing this issue! I have a e-commerce with 300 items on CMS and my webflow designer is so slow and laggy, I can’t use it for 20 minutes straight without refreshing the chrome page because it gets slower with time.

I really think that fixing this issue should be Webflow’s team top priority. As I keep adding more CMS items, the lag starts building up and it’s getting really difficulty to keep working on it.

I hope Webflow can solve this issue and make webflow fast again, soon.

1 Like

Imagine how we’re doing on 7000 items…

Why even have a 10.000 item plan.

And yeah, I agree. The entire system is in dire need of a performance overhaul. I know the team is working on it, but it’s getting worse by the day. I hope this is the top priority.

1 Like

It may be bad luck, but I’ve noticed degradation of performance in just the 3/4 months we’ve been using Webflow.

Suddenly, the editor becomes totally unresponsive and we lose an hour or two of time.

Maybe a coincidence, maybe related, but I’ve also noticed that publishing has been unreliable. I’ve spotted our own site being affected by 404s in the last few days following some updates. There was absolutely no logical reason for it. Republishing didn’t help, but refreshing the page 20 minutes later and the issue had gone. This particular one is very concerning, and we’ve created some synthetic monitoring on our site to see how often this occurs.

1 Like