Streaming live at 10am (PST)

The published look doesn't look the same as in designer panel

Hello guys,
can anyone help me with this issue? I don’t know why the published view doesn’t look like the layout in the designer panel. I have tried to refresh the webpage multiple times and also updated my browser too. It didn’t work. Please help me to figure it out. Thanks a lot in advance


Here is my site Read-Only: https://preview.webflow.com/preview/e-ouyang-c8e8ae9bf33b2add054304837ac402?utm_medium=preview_link&utm_source=designer&utm_content=e-ouyang-c8e8ae9bf33b2add054304837ac402&preview=8c7dd13aac1282eb3df4bcb96b966c7c&mode=preview

[1] designer read-only link: https://preview.webflow.com/preview/e-ouyang-c8e8ae9bf33b2add054304837ac402?utm_medium=preview_link&utm_source=designer&utm_content=e-ouyang-c8e8ae9bf33b2add054304837ac402&preview=8c7dd13aac1282eb3df4bcb96b966c7c&mode=preview
[2] published link: https://e-ouyang-c8e8ae9bf33b2add054304837ac402.webflow.io/

You set that gap in various way in the style panel and IX,

I guess when the page loads, the IX takes the positioning over with the Transform rule, before the Position left -35% kicks in.

Maybe straightening it up will solve the bug:

  • Select the Contents element, and with the inherit menu, select just the first class, .contents.
  • Alt click the Left value label in Position to cancel it. Should be back to Auto.
  • Add a Transform Move x of 33vw
  • In the IX, replace the -39 value at 0% by the 33 value.

Now the element is positioned using the properties you’re using in the IX. I hope that fixes it.

As much as you can, don’t take IX by surprise, try to prepare the ground by declaring the properties that the IX will play with, even if the values are 0.

1 Like

Thank you for your comments! I followed your all instructions except the last one. because I’m not sure what do you mean the IX in English? (I’m not a native person and not good at code too, new to webflow), even I didn’t change the value but it still works!!! Thank you sooooooo much!!! :laughing: @vincent

I thought it works, however, it becomes the opposite situation in all breakpoints. Crying…

designer read-only link: https://preview.webflow.com/preview/e-ouyang-c8e8ae9bf33b2add054304837ac402?utm_medium=preview_link&utm_source=designer&utm_content=e-ouyang-c8e8ae9bf33b2add054304837ac402&preview=8c7dd13aac1282eb3df4bcb96b966c7c&mode=preview
published link: https://e-ouyang-c8e8ae9bf33b2add054304837ac402.webflow.io/

Would you please tell me if I messed up it?

The interaction. Change the value in the interaction too.