Streaming live at 10am (PST)

Too many redirect SSL - Custom domain configuration OVH

Hi!
I’ve seen many having this issue with webflow before. Except that my case seems different.
I configured my domain today (10 hours ago). I tried both SSL and Non-SSL configurations, each time resulting in a non-working website.
Afterall, I need SSL so even non-SSL config would not be great.

With SSL, it gives an error : “ERR_TOO_MANY_REDIRECTS”.
I removed every non-webflow A records + CNAME www. Changing “default domain” in Webflow Project Hosting Settings doesn’t doo anything.
I’m kind of stuck. My client’s website is down because of this. It’s not great actually.

Thanks for any of your help.

Do you have any 301 redirects setup under the websites settings > hosting tab?

1 Like

This usually happens when the DNS settings or the webflow domain settings are trying to point to domain.com instead of www.domain.com and the SSL certificate is specifically looking for www.domain.com

the www. (dot!) missing being the issue. Can you DM me your exact DNS settings from the domain hosting (dont post them publicly) and show me your webflow domain setup in a screenshot?

Also, did you try flushing your DNS cache? Google how to do it on your machine.

1 Like

Hi! Thanks for your help. I’m not able to dm you. I’ve all the screenshots ready.
(There are no 301 redirections set on my hosting section)

@Ozone Maybe send me a private message first, I feel like my actual role on the forum does not allow me to create private discussions.

That’s weird. Your DNS seems ok to me. Have you contacted webflow support? They might be able to see where this goes wrong.

1 Like

I’ll do that. I just wanted to be sure nothing was terribly wrong so I would not bother them in these difficult times. Thanks for your answer. I’ll keep you informed.

I finally got my DNS to work.
I added a custom TTL of 300 for both A and CNAME records. This is something related to the default value set by OVH when adding a dns record. I did not put a lot of thinking first into this setting.

After that, I republished my website through the editor, and it’s working fine now.

Sometimes, the error page with too many redirections shows up for a second and disappears leading me to the website without another issue.

I’ll be sure to take note of it. This will save me some headaches.
Thanks everyone for yours quick reponses.

1 Like