Streaming live at 10am (PST)

Too Many Redirects Error Message ERROR

Hi

I’v an issue with one of my pages …
I hosted the site few days ago…

“thejunction” have an error message
HELP PLEASE
Help please?

www.f2vc.com

Artboard 1 copy-100 Artboard 1-100

Hey!
For me, your site loads perfectly. Opening the http version has a permanent redirect to https version.
Where do you face that error? Only in the browser?

All browsers have same issues…
on “thejunction” page (see on nav bar)

Any suggestions please?

have you checked your 301 redirects? I can see in the screenshot that you have set some rules, could it be that there’s a interference?

The code looks fine, without a read-only link I’m not sure how to look deeper into this…

this is the read-only link

https://preview.webflow.com/preview/f2vc-b5bef1f9e469314580fd-95e698aadf5ba?utm_medium=preview_link&utm_source=designer&utm_content=f2vc-b5bef1f9e469314580fd-95e698aadf5ba&preview=bd1a5fb92ef38a2ff445dbe066b309f4&mode=preview

maybe it could help you to check?

Looks all fine and dandy tbh :confused:
You did check all your 301 redirects, did you?
After navigating to /thejunction I get loads of 301’s:

This feels like two 301 rules messing with each other!

:frowning:

sorry this is my first site I hosted…
What actually I need to resolve this issue?

In your initial posting you provided a screenshot of your project settings

  1. Go to your “Project Settings” and open the second tab “Hosting
    image

  2. Scroll down to the “301 Redirects” section

  3. Inspect all rules that you set:

Each rule has an “old path” and a “redirect to path” value (path/location).
Look for rules that include your problematic “thejunction” string.
My best guess is, that there are two rules intersecting each other, creating a loop?

I’m hoping my assumption is true, otherwise I’m really sorry :frowning_face:

Oh I delete the specific redirect for this page and its OK now!
I hope i didn’t mistake that i delete this one …

Thanks a lot my friend!

Very glad this worked!
If you change the location of a page, users that bookmarked that old location or search engines like google have indexed that old location, they will see the 404 page not found page.

WF usually warns you inside the designer when changing URL’s and folders and/or moving them!

To solve this, you can manually set those 301 rules, so that you can tell the visitors of that old location where the page has gone to!

Be careful when setting those rules :slight_smile:
Can you mark my answer as the solution, so this topic is closed?

Have a nice weekend and be safe :webflow_heart:
If you need help with anything else, feel free to ask here in the forum!
Always happy to help!

1 Like

Thanks for this!
Have a great weekend :blue_heart: