Streaming live at 10am (PST)

Too Many Redirects , Page won't open

Hi, working on a website and now one of the pages won’t load. Safari says it’s got over 20 redirects, however I haven’t added any.

I’m still on the .webflow.io domain.

https://casachiqui.webflow.io/accesorios

I tested on Safari and Chrome. Tried clearing cache and cookies, to no effect.

I checked an online tool ( http://www.redirect-checker.org/index.php )for redirects and it seems it keeps redirecting from the same URL over and over, not to a new one, but to the same URL about 20 times. i.e.: from /accesorios to /accesorios to /accesorios etc.

I figure a possible fix is to copy the page, delete the original, and replace the same URL I used before might fix this, but it’s not ideal and it worries me that all of my pages might be accumulating ghost redirects and break at any point, as well as being penalized by Google for bad SEO.

My client and I were planning on launching, so this is a real nuisance, thank you for your help!


Here is my site Read-Only: https://preview.webflow.com/preview/casachiqui?utm_medium=preview_link&utm_source=designer&utm_content=casachiqui&preview=7dad976d3b4bc6804e54fa0682bb7ffc&pageId=5f204d9b6c7a90efb1600208&mode=preview

@Yaco - do you have redirects set up in your site settings that could be causing this?

None at the moment @sam-g , this is why it’s weird.

I just noticed a new site posted on the facebook group Webflow Designers (Global) has the same issue:

It seems mine might not be the only case.

@Yaco - that is interesting, especially being on the webflow.io subdomain. Can you clone the project and try again? Otherwise, I would recommend contacting support in this case.

Thank you Sam. It turns out Webflow had added a few redirects.I deleted them and support offered a way to prevent this for anyone who might find it useful:

The “too many redirects” error is related to not having the correct default domain selected.

You can review this: regarding why your domain is not connecting and receiving the “ERR_TOO_MANY_REDIRECT” Message.

This is because the subdomain www. is not set as the default domain:

Shared with CloudApp

1 Like