Streaming live at 10am (PST)

Transition interference with interaction

After setting a scroll interaction on some image elements, the interaction is jerky. When I turn the existing CMS transition for the same element off, the interaction becomes smooth as I want it to be.

Ideally, I want to keep both the transition and the interaction.

Does anyone know how to fix this?


https://freelancedan-01.webflow.io

https://preview.webflow.com/preview/freelancedan-01?utm_medium=preview_link&utm_source=designer&utm_content=freelancedan-01&preview=3c2f6e074748ff6a652762715816dd5f&mode=preview

Hi @freelancedan,

Try to replicate the behavior in incognito mode and/or a different browser… I have tried to see the issue you are talking about but I do not get the same behavior… also your layout seems a little out of whack…

Thanks. It’s a work in progress and things went a tad astray while I was fiddling around on another page.

I reset everything, tried Chrome in incognito mode and it’s still doing it.

The animation works but not in one smooth motion. As soon as I deactivate the transition, it’s fine.

I am thinking it is some sort of a glitch, so just replace the transition with a second interaction for the same element but make it a hover interaction that scales the image… I tried it and it works

Okay, I’ll try that, thanks.

Do you think the glitch is worth reporting?

I cannot see an issue currently in your read-only but I think it is because of you targeting the same element with different interactions. Put your element inside a div and target this div with your second interaction instead.