Streaming live at 10am (PST)

Trouble with click interaction targeting DIVs


#1

I have re-tested this, and it looks like a bug. I have come across this issue with others webflow pages i was trying to make yesterday, and now i decided to do it from point 0 so i can post it in the bug section.

Please take a look into it, they way we need to make landers, depends on the following actions:

What i wanna accomplish is easy, i have 5 divs that have 5 buttons, each div have one of those button, when we click in one of the buttons, we change the display of the "container"div to none,

So, when we are making the site, we copy and paste the divs, etc... off course we change the divs name, buttons, and everything in it, so we can hide it properly when we click the button inside that div.
div1 - > button 1
div2 - > button 2
.... etc

But when we click in one of the buttons(anyone), always the div4(in this case, in other cases its other divs or element) get the property to hide. So it hides the current div(the one that has the button inside), and other div...

One strange thing that we noted is that, when we make a page from start(blank page) and we set up everything(the page itself, and the interactions in the object panel) it works like its supposed to be, but when we decide to add more divs, buttons, copy and paste(change properties names to make them unique) it start to have this kind of mistake.

Maybe we are doing something wrong, and its a silly mistake on our part, we are very new to webflow, just a week using it, but we are in the need of help.

I will provide a screencast, and the public page.
(doing the screncast, i noted that no matter where i click on the page as you will see in the screencast, the div4 dissapear, it change to display: none)

screencast: https://www.dropbox.com/s/dj1b5y1122b30d5/webflow.mov?dl=0
public page: https://preview.webflow.com/preview/probando-multiples-acciones?preview=61e60651fa536950401c28375bfea9e1

I LOVE WEBFLOW!, please help me with this issue!!

Tx, Bruno


#2

Can you please provide a public share link? Thanks! :wink::+1:

https://help.webflow.com/article/how-do-i-share-my-sites-read-only-link


#3

Tx for the link vladimir, i have edited the post with the correct link!

also here it is: https://preview.webflow.com/preview/probando-multiples-acciones?preview=61e60651fa536950401c28375bfea9e1

tx, Bruno!.


#4

It is weird and even kinda funny :smiley: I tried to delete div4 and add more (div6) and everything works fine. So just do not use "div4" classname :wink:


#5

Hi @inovu, thanks for the post. I took a look and it seems the hide-div4 interaction is also applied to the section directly under the body.

I would suggest to remove that interaction on the main section, and it should work as intended.

I hope this helps!


#6

Great!! It worked, i didn´t noted that i have that interaction in the section, maybe when i copy and paste it i made some mistake!

Tx to all for the responses!

tx a lot!


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.