Streaming live at 10am (PST)

Trouble with clipping shadows


#1

I havent experienced this behavior before so I have marked it down as a bug.

Notice that where the red boxes direct you to the shadow is suddenly cut off. This happens with both setting shadow settings on a div block and an image.

There are no other componets that could be causing this cut off. I have checked.

I am using Vivaldi 1.1.453.52 (Stable channel) (64-bit) which is the recent one.
This is being done on an iMac 4k.

Due to the sensitivity of the project I can only allow Community Experts and Webflow staff to see my read only link. Sorry about that.

@Waldo @cyberdave Please help if you can. :confused:


#3

That's not a bug that's your structure cutting off your shadows, either because the parent has overflow:hidden or is too low in Z. When you do shadows like this you need to make room around for them to spread. Even when Gecko and Webkit don't cut them off, IE will, it's a known thing.


#4

Solution:

Ok.
So your images sit inside the row, which is inside the slider. Slider mask by default has a settings overflow: hidden. This is why shadow gets cut.

For fix it, give a Slider Mask some class, and add top and bottom padding. Sure you will have to increase slider height too.

Cheers,
Anna

The problem was fixed. Thank you to @vincent and @sabanna for the great help. :grinning::wink:


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.