Streaming live at 10am (PST)

Trouble with Link Paths on exported site/.htaccess


#1

Guys,

When I go into my new website (photography website) Shared link below and change the Home page link to simply / so it reads the index, when I upload the page it shows the link as /home. I have tried deleting the link and then redoing the link.

Live link is here: http://mywebmb.com/jill/

I have the navigation as a component that is copied everywhere in the website.

Can someone please take a look at this and see why this is happening. ** I have never had this issue in the past. **

@cyberdave @sabanna

Thanks,
Sean


Here is my public share link: https://preview.webflow.com/preview/jmp1-c9db01c7011b78241c88b2398d1f0e73?preview=381841ee983b12e4817b48f42ecf9cc1
(how to access public share link)


#2

Hi @seank, thanks for reaching out. Here is what I see:

I am not sure if I quite understand the issue, could you help to clarify?

Thanks in advance!


#3

@cyberdave - click on another link and then try home.


#4

Did you try using Webflow page link settings?


#5

@sabanna - I thought I could make it say / and it would recognize the index if i renamed the file to index?


#6

@sabanna i did that and it still doesn't work on the live uploaded site.


#7

Owww, so you have an issue on the exported site?


#8

Hi @seank,

For the home link, change it to

/jill/

#9

Hi @seank, I was just leaving another message, I would try @samliew's suggestion :slightly_smiling: If that does not work, could you share the contents of the server .htaccess file?


#10

@cyber' @sabanna @cyberdave

Removing the htcaccess worked. How else can we hide the /pagename.html extension via webflow on exporting? I know when hosting it works, but we really need to see how we can get the export hidden .html to work.


#11

Hi @seank, well, for Webflow sites, this is automatic, but for external sites, this need to made in the .htaccess file.

Here is a good article on the subject: https://alexcican.com/post/how-to-remove-php-html-htm-extensions-with-htaccess/

.htaccess can be tricky, and sometimes just need a little trial and error until the setup works as intended.


#12

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.