Streaming live at 10am (PST)

Trouble with Mailchimp integration


#1

Hello Cyberdave,

I'm really sorry but the solution presented in your tutorial doesn't work... I get the error message. Could you take a look and tell me what is not working? Thanks.

Here is the read-only link: https://preview.webflow.com/preview/leftproductions?preview=69e6f38d3427d2aa77f0dcfb25d06a6a

Thanks very much.
Augustin


MailChimp signup form integration
#2

Hi @LeftProductions

Can you provide a screenshot of the error and the name of the page it's happening on?

Thanks in advance :smiley:

Cheers,
Nelson


#3

Hello PixelGeek,

It's happening on every newsletter tab (on the homepage for instance). Here is a screenshot

Thanks very much,
Augustin


#4

for you action, replace: http://leftproductions.us8.list-manage.com/subscribe/post?u=2069d1e14887439a561a2261f&id=db4861cdcb

with //leftproductions.us8.list-manage.com/subscribe/post?u=2069d1e14887439a561a2261f&id=db4861cdcb

also, set your METHOD to AUTO


#5

Actually, the solution suggested does not work. I have the same problem... Since the website is public, I put it back to the default settings... Do you have any other ideas? Thanks very much.


#6

HI @LeftProductions, thanks for the followup. If the form has only a single field, it could be that Mailchimp may be getting a bit more strict about the fields it is expecting in the form.

If your Form only has a single field, you might need to add a custom Embed block within your Form element:

Save change and republish the site, then submit a new form entry and check to see if mailchimp receives that. It would be helpful also to have a screenshot of your form field list in mailchimp to see what fields it is expecting. I hope this helps!


#7

Hello cyberdave! I have the same problem. The form sucessfull message appears but i don't receive the subscribe on mailchimp list. I tried using a single field and more fields, but still don't work.

I don't want to use the embed block because i want to keep our design style. Can you help me?


#8

Hi @evekayser, sorry for the delay in answering, do you have a read-only link to the site, where I could look at the way the form is setup in Webflow? Take a peek here: http://help.webflow.com/faq/how-do-i-share-my-sites-read-only-link


#11

Hey @evekayser can you please try updating your post again with your read-only link? It looks like the one you posted is broken :confused:

Thanks in advance! I'm happy to help, just tag me @Waldo once you've updated your post :smiley:


#12

Sorry, I am sending again: https://preview.webflow.com/preview/evekayser?preview=c427be49592d21fb6d34987c868b2b47


#13

Hi.

The form that I am testing is on page (evekayser.com.br/posts/...)
https://preview.webflow.com/preview/evekayser?preview=c427be49592d21fb6d34987c868b2b47 (refreshed)

I also tried without "http" but it isn't working...

Can you help me?


#14

Hi @evekayser

I checked that dynamic template page and I do not see a URL in the form action area. Can you try adding it again?


#15

Hi. Its on the yellow Section that appears with interaction in the end of the page. (evekayser.com.br/posts/.....)

https://preview.webflow.com/preview/evekayser?preview=c427be49592d21fb6d34987c868b2b47

Its the form inside the "Anzol" section.


#16

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.