Streaming live at 10am (PST)

Turning off web-kit dropdown styling in safari


#1

Hello again :slight_smile:

I was reading about how you can turn off the gel-box styling of safari’s dropdowns with the code
-webkit-appearance:none;

But it hasn’t worked. Its possible I am embedding it wrong as I’m no code expert… which is why Im using webflow I guess !

See below for the culprit in question.

I want to turn off all styling, as I have styled a div underneath it to match how I want the form to look.
You can view http://semasio.webflow.io/contact on chrome for a reference on what I’m after.

Thank you!


Here is my site Read-Only: https://preview.webflow.com/preview/semasio?preview=a4c19a8b6f78f2fefbfff25a84e7ed5f


#2

Yeah this is a common problem. You’ll need to add custom code to get this working for all browsers consistently.

https://clicknathan.com/web-design/styling-select-elements-crossbrowser/