Streaming live at 10am (PST)

Two fixed elements not staying fixed in preview mode - modal and CTA button


#1

Hi there,

I am having a similar issue in that a CTA button ‘fixed’ to the bottom right of the screen fails to transition in half-way down the screen, instead is fixed to the bottom of the Body.

This issue has now applied to the modal form triggered by clicking the apply now button at the bottom - it appears fixed to the top of the Body opposed to filling the viewport.

I have no idea why this has suddenly occurred.

Read link: https://preview.webflow.com/preview/marieclaireenergymedicine-b775c5686eddd?utm_source=marieclaireenergymedicine-b775c5686eddd&preview=06a53145d1ba54724f9e6efcea584b3a


#2

It’s because you have scroll into view trigger on the second to the last section that triggers the button to slide in. Remove this and it will show all the time.


#3

So I am aiming to have this button transition in regardless, however both the CTA and the Modal are fixed to the Body top and bottom (start and end), after transitioning, instead of the viewport.

Something is causing them the remain fixed to the Body over the viewport - I can’t work out whats going wrong!


#4

Right some problems FIXED as there was a move Body 0px left in a transition which caused the positioning problems of the modal and CTA button.

There are now more irregularities occurring:

  1. Hero transition nows skips a portion of the opening segment

  2. The slider control arrow halfway down the page no longer works nor the one on the modal (activated by clicking apply now near footer)

  3. The slider on the modal also now shows the other slides which should be hidden and the ‘previous question’ and ‘next question’ controls no longer function.

Help @cyberdave and @DFink - Avengers Assemble!


#5

For the slider, you changed the mask to be overflow:visible which is why it’s showing the other slides.
I’m not sure why the slider isn’t advancing but I have a feeling something was changed from the default slider that broke it. Can you roll back to a backup to see what changed?

@cyberdave do you think you can dig in more into this. This site uses a lot of interactions which I can find very confusing.


#6

Hi @DFink,

Thank you for scouting out that Overflow setting for the slider.

I’m currently running through the site from a previous backup and defining what has changed - cheers for the advice.

@cyberdave if you have anytime at all to take a look I will be eternally grateful.

Many thanks guys!