Streaming live at 10am (PST)

Unable to copy/paste text into text blocks?


#1

I’m trying to copy/paste a few poems, nothing too long, into a text block. Sometimes the copy/pasting works, and sometimes it doesn’t. I’m not sure what the deal is, but I’ve tried it in multiple browsers. Anyone know what I should do?


Pasting rich-text
#2

Hi @troyANFT

Do you mean from Webflow project to Webflow project? If so, make sure both are open and use the keyboard shortcuts to copy/paste (cmd+c cmd+v or ctrl-c ctrl-v)

If you mean from another source of text - best to make sure you have the text unformatted - so copy and paste from notepad for example.

Or if you mean with Rich-Text - see this post and reply from @vincent for some clarification:


#3

I mean from other websites/text documents to Webflow, sorry I wasn’t specific.
I tried copying from plaintext and that worked. Thanks!


#4

Uhoh. One attempt worked, and after that it is not working.
So I’m pasting the text into Notepad, then ctrl+shift+v into the text block, but it still doesn’t work.

This only occurs if there is already text in the text block.


#5

I guess it’s picking up on some styling that’s already there? Feel free to post a short video (cloudapp seems best) to show specifically the issues you are having…and the good old read-only link :slightly_smiling_face:


#6

Yes there’s a bug presently. For example if I select all the text in a paragraph, then past new one, it just adds the text, not replace it. So I need to clear the text before I can copy new one. So to update a block, I copy the text from the block, edit it in a text editor, then clear the block and paste the result at once.

@brando the paste text bug is filed somewhere right? or do you need us to document it? To reproduce it, select the existing text of a paragraph, then paste new text to replace it. It should just add the text.


#7

Hi @vincent :wave: Yes, the paste bug where pasting text doesn’t replace existing text is filed. It looks like this only happens if you select the text with CMD+A. If you triple click into a text element to select all the text, then paste will replace it as expected — it will also work if you use the mouse to select the text.

I’ll definitely share an update when we have a fix pushed for this though. Thanks for your patience!


#9

I’ve also been noticing this bug for a week or so – good to know about the triple click method. Look forward to a fix…


#10

Ah good to know! I’m a cmd+a guy.


#11

Any word on a fix for this? It’s still very much present—me and my colleagues have been encountering it often enough for it to be a bother when working with text inside Webflow.


#12

This is still not fixed. It’s rather annoyed. And triple-clicking does not work for me either. I can’t copy any text at all from Webflow. I can only paste text into Webflow.


#13

Hi @timcricket, are you able to copy text from Rich Text to another Rich Text block? that text in the rich text is converted to html elements, so it may be you are unable to paste those into the plain text block.

Are you able to copy from Rich Text, then paste and match style (right click in mac, or copy to notepad and then copy text and then paste into text block.)


#14

I can confirm that no text can be copied from webflow designer. Copy from preview works as expected.

edit: from webflow to anywhere else at all. It is as if no copy into clipboard is happening.


#15

I am having the same issue with ctrl-c and ctrl-v or copy and paste selected from rightclick,
It doesn’t work while trying to copy from another webpage to a paragraph in webflow, and also when I am selecting a text inside a paragraph and trying to paste it in a different position in the same paragraph.
Looking at the original poster (june 2018) I am curious if this bug is being addressed and more info to it @cyberdave or @Brando ?


#16

Hi @dram @Gijs_1

The original issue here has been resolved.

I may be misunderstanding this issue you are talking about, but on this end it appears copying text and pasting it into the Designer work as expected:

As does copying text from the Designer and pasting elsewhere (in this example I pasted into Notes):


#17

Works as intended now, thank you very much!


#18

I still had problems but a ‘workaround’ I found:
Paste the text in the same sentence as existing text, right behind the last character (leave no space).
If you don’t have text, you can type some yourself.
I found out by accident so maybe it can help others experiencing this problem too.