Streaming live at 10am (PST)

Unable to Delete CMS Collection


I'm unable to delete a CMS collection with zero items.

I've deleted all elements from the collection page as well.

I've searched all remaining pages and their elements, but cannot find any references to the collection I want to delete.

I've already sent @webflow an email. :wink:

Here's my share link:

Unable to Delete CMS Collection with 0 items

The error message is

Path not found: /api/v1/collections/58c112ce83693a0e105da805

That doesn't sound like tht typical error you get when you've left elements on pages. So, it's be best for the Webflow team to look into this, I'd say.


Thanks for taking a look!

Just curious, how'd you find that error? Did you use a browser inspector?


It should just pop up top right of the page when you try and delete the collection:


Wow. I was able to replicate that using the share link.

I'm getting the standard error, "Cannot delete this collection as it is used in bindings" inside my designer (not using the share link).

"This field is currently used in Dynamic Template Settings. To delete this field, you'll need to remove any references to it first." also shows up when I try to delete some fields from the collection called "Delete".


Hi @anonmusic

I've performed a hard refresh of your site from my end. You should be able to refresh on your end and delete that collection item now.

​Please let me know if this solves the problem, if not, I’m happy to help further :slight_smile:


Thanks @Brando! Hopped into my site, and deleted the bugged collection in 2 seconds!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.