Streaming live at 10am (PST)

Unable to Remove Bold Span from Text Link block


#1

Unable to remove Bold/Span

How to reproduce error:

  1. Create Text Link Block, input few words text
  2. Make end of link block ‘Bold’
  3. Select Mid section, and CTRL+→ then Backspace

Work around:

  1. Create new Link Block
  2. Bold entire link block, unbold

Why is this an issue?
I have a particularly formatted link block with multiple spans for a style. Unable to remove Bold Text span messes up canvas.

Clear formatting does not work
image


#2

Copy your text and paste it in again should solve the issue.


#3

@mac_heibu

no bueno :frowning:


#4


image
image


#5

Didn’t say that.
Select all text, copy, delete, past in again.
Just have a look here: https://forum.webflow.com/t/ghost-elements-how-to-get-rid-of-them/68771


#6

@mac_heibu
Does not work :frowning:


Row 3 represents copy delete paste

  • Text ‘status’ is intentional Bold and working as intended
  • the {{{ $status->ifOffTrue }}} {{{ $status->ifOnTrue }}} is working as intended via span (shows Red OFF or Green On Only on render)
  • span class “data-id” attributes work as intended.
  • The Bold introduces flex issues on mobile variant.
  • Copy delete paste solution does not work for this span instance.
  • Bold whole block + unbold resolves the issue if Bold is between spans.
  • Bold + Unbold does not work if END of span is a bold span.
  • Copy delete paste solution does work for generic text or ph blocks.
  • Workaround I manually re write this text block (span-class, data-id) . Unfortunately this is in a bunch of span fields.

image
Unable to resolve using

  • Copy Delete Patse, does not work
  • Bold All Unbold, does not work
  • I must manually write new block and class-id and ctrl+shift+v paste contents without meta characters

#7

Hi there. :slight_smile: I’m happy to help look into this.

Can you please post your read-only link?

thanks in advance.


#8

https://preview.webflow.com/preview/html-sandbox?utm_source=html-sandbox&preview=3fbbcb13f66c0d08ffbab4999b125e52

http://html-sandbox.webflow.io/bold-is-not-being-removed


#9

@miekwave

This is a pretty unique edge case in that you have several spans in one line with the parent text block set to flex.
I was still able to remove the bold from part of the text though:

I’d recommend building this out a different way for more flexibility though. A parent div set to flex with three different text blocks inside. This will make it much easier to work with, I think.


#10

@Brando

I need to take out the middle bold unit

“I’d recommend building this out a different way for more flexibility though. A parent div set to flex with three different text blocks inside. This will make it much easier to work with, I think.”

I get what you’re saying. In this project the
Statuses are in another divblock in a columns nested in a wrapper.
Plain text statuses are fine.
Then Client wants on off status indicators (red green tint) so made {{{ $statusIfOn }}} {{{ $statusIfOff }}} which display correctly (only On will say ON with Green, or only Off will say Off with Red.)

The problem is when Off is being diplayed, the Bold Text in between interfere with flex arrangement

Moving this into seperate div block format still has wrapping problems, unless we rewrite {{{ display:hidden }}} into , but thats another issue…

As a work around I just did it all again from scratch and reset all the data ids. It’s just tedious as I feel like not being able remove unwanted code ( <strong> ) is a bummer and I consider it bad user experience.