Streaming live at 10am (PST)

• Unable to scroll canvas


#1

Hi i published my website a while ago which works perfectly fine but when i go the editor i cant scroll down and i cant seem to be able to scroll down in preview mode too. i didn’t make any changes or touch the editor since the working website and im worried if i publish it it might have the same problem. how can i fix this?

here is my shareable read-only link: https://preview.webflow.com/preview/iby?preview=dc50050e4874d49669259a080145732e


#2

I’m having the same problem, just came back to work on my project after a few weeks off and can’t scroll down!


#3

Strange behavior indeed!

So I got your website to work by putting some stuff in divs and changing some settings around.
I put everything into a div named page-wrapper that had only position: relative. After that, I put everything that was in the header (background video div, heading, and the button to bottom) into its own div named header with the properties width: 100% min-height: 100vh position: relative. I also changed the heading div with your logo and tagline to no longer have a margin of 31vh and gave it a top: 31vh property under position: relative

After doing all of that your page was working again.


#4

@bbrazis does the header div stay within the page-wrapper or should be outside of the wrapper as a separate thing in the navigator?


#5

Put everything inside the page-wrapper.


#6

Hi @Iby, thanks for the post, I tried looking at the read-only link, but it seems that the link is no longer valid.

There is an open issue at the moment where adding top or bottom margin to an element just under the body and then having another elements added that go beyond the body viewport vertically will not scroll.

The workaround at the moment is to use padding instead of margin with no elements under the body having margin, or set the body to overflow auto.

The issue does not happen on the published site as that emulates the “standard browser behavior”. Eg. if you publish the site it will scroll because it will have that behavior which is being undone somewhere on the body or html tag in the designer. As soon as I know a fix is out for this, I will let you know immediately.

Thanks in advance.


#8

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.