Streaming live at 10am (PST)

Unexpected section showing when pre-loading

#1

Hi there,

My website is experiencing an unexpected error. As shown in the screen video, there’s always some elements from the page section showing up very quickly before the preload image even shows up. Could anyone help me and let me know how to get rid of that please?

Thank you!!


Here is my public share link: joykkong.co
Here’s my read-only webflow link: https://preview.webflow.com/preview/sunnypoem?utm_source=sunnypoem&preview=ac8343f513a7f9a85b74763dd58c255e

thank you so much!

#2

If they are not hidden as the default state, the browser will display them as soon as they are loaded. You can’t control the order of resources fetched. You can set the elements to display:none and then programmatically change the display: value. IX for example.

Here is a better explanation of what is happening and how you can deal with it.

#3

thanks for your reply… could you please elaborate more on how I could make changes in webflow step-by-step?

#4

hi Webdev,

I just tried to set display: none, then in “page load” to show the “waves” section. However it’s still not working :frowning:

#5

You might want to clear your browser cache and then check. Seems to be working on your published link for me.

#6

thank you. Originally the preload div was set to display “none” on the page. I tried to set preload div to display “flex” and it’s working now :wink:

#7

You’re welcome. Looks nice. Glad you resolved your issue.