Streaming live at 10am (PST)

Unidentified source of color formatting

I’m working on updating my website. I added a few new pages and I noticed the wrong color on the navigation. I went to fix it and it’s not in the original and on the hover. There is no other formatting. I thought it was because of the “Current” state, but it’s not. I erased the class and the original unaltered nav link does not have that color. I have no idea where that color is coming from, so I can’t fix it. I tried a few things and erased some. But still, I can’t find where is that green color coming from. The “Advisor” link is displaying with the green. I looked in “All Links” but I can’t see a difference. I checked the class “Visited”, but it seems salmon color too. No idea where the green is coming from.

The class has the Original State as Peach/salmon color, on Hover Grey. The Current state has original Green, Hover turns each/salmon and “Pressed” grey.

There must be something I’m Missing. If anyone can help me, It would be greatly appreciated.

Thanks,


Here is my site Read-Only: https://preview.webflow.com/preview/marialicia-leon?utm_medium=preview_link&utm_source=designer&utm_content=marialicia-leon&preview=0c43ac438a97f4e1408c696d4efe9cb2&pageId=5d1d7da308905734b3ef471c&mode=preview

Published site: https://marialicia-leon.webflow.io/

Screen Shot 2020-02-04 at 12.52.42 PM

Hi @kaira18,

Are you still needing help? When I click on the share link it looks to be resolved. Please advise?

Best Regards,
~ Brandon

Thanks for your reply, Brandon!

It is not resolved. Those letters in the navigation are orange (salmon color). Home should be Salmon color and the Advisor also. The only one that is Real is the Biography one. That one is supposed to be green because it is the “Current” one. The rest should be orange and turn gray on hover.

On the home, the only one that should be green is the one that says Home. The rest is really Orange.

If you look closely, the “unexplained” green is another tone, like a bright green.

@kaira18

What browser are you seeing this on? When I viewed on Chrome I only saw Orange and grey on hover.

Anything more you can provide would be great?

Best Regards,
~ Brandon

I’m in Chrome as well, in an iMac. I cleared the cache and cookies, just in case, but it looks the same here.


This is bizarre. At least I have the hope that people would see it fine on their computers. I’m totally clueless. I opened the site on Safari. The navigation was orange, but after I clicked them they turned the weird green color and stayed like that. There must be visited or pressed formatting. But I don’t see any. Screen Shot 2020-02-05 at 9.48.11 AM

Thanks a lot,
Marialicia

I think I found it!

I made a link and used it to find the “All Links” class and it has a “visited” status. Guess the color… Green! I changed it to Orange. :smiley:

Is there a way to eliminate a “pressed” or “visited” class specification after it has been set? For me, this will work like it is because it is not all green anymore. But I wonder, for next time, if I don’t want the links to show different, how can I return it to normal?

Hi @kaira18,

Actually you can do that from the link you were testing on and just repro those same steps. Element of the link, link Hover, pressed, will have a blue dot next to it to let you know that changes have been made to its default property. TBH, I didnt even think to look at the visited element. Good for you for figuring it out.

Best Regards,
~ Brandon

Thanks :slight_smile:

Now I can be the missing color detective. :wink: I’m glad it worked out. You did give me the clue about what to look for when you told me you were seeing it the right way.

@kaira18

Thats a great way to think about it.

I wish you luck and happy designing in the future.

Please let me know if you have any other questions,

~ Happy Designing ~
Brandon