Streaming live at 10am (PST)

Update on Zapier ValidationErrors


#1

A number of people have been running into issues with unhelpful errors from zapier so I wanted to provide an update on some changes we made that hopefully should make them more useful.

When our API gets a request to create a CMS item where the provided data doesn't match the schema of the Collection, we return a ValidationError. For most API consumers, the returned value is useful and looks like this:

{
  "msg": "Validation Failure",
  "code": 400,
  "name": "ValidationError",
  "path": "/collections/58815a5371f812939a0d6b08/items",
  "err": "ValidationError: Validation Failure",
  "problems": [
    "Field '_draft': Field is required",
    "Field 'option': Value is not a valid Option: 123"
  ]
}

where it shows exactly which fields are failing validation.

However unfortunately, Zapier does not display the full error message, they show what they believe to be the "important" bit of it - which in our case, is not all that useful.

I just updated our error handling code specifically for Zapier to try and "trick" it into displaying a more useful message. It still is not perfect as it still is truncating the message, but hopefully now the error should at least be a little bit more useful.

If you're still seeing cryptic messages, let me know and I'll see what I can do to fix them. I've also reached out to Zapier's support team to see if there is anyway we actually can control the exact message displayed.


Zap Validation error
API/Zapier error! Anyone familiar with this error?
#2

Hello Nathan,

unfortunately no help for me with my latest situation... Trying to connect instagram to webflow. All worked fine first but then:

Any ideas? Collection is at zapier.webflow.io/granowall


#3

I've reached out to zapier's support about this error - I can replicate it and I too see nothing. However our API did return a normal error message. In this case, the error not being displayed should say You’ve created all the items allowed on your current plan. Add CMS Hosting to create more.


#4

Thanks @nathan! I forgot the 50 item limit. All good now with the upgraded plan.


#5

Hey, I'm getting the same error and I can't figure out why.

I'm getting data from Typeform and I checked that Reference fields are a perfect match e.g. they can choose "PR" on the form and I have a collection called "Category" which has a collection item "PR". There 3 such fields. I assumed that perfect match will work. Is this the problem?


#6

When i try to submit request to create a CMS item it’s display Error
{“msg”:"‘fields’ is required",“code”:400,“name”:“ValidationError”,“path”:"/collections/5b8fc640345da665caccdcd6/items",“err”:“ValidationError: ‘fields’ is required”}400

i try to submit data array with curl post method :

Here is my requested array format:

{ “fields”: { “name”: “99 Norfolk Street”, “slug”: “99-norfolk-street”, “_archived”: false, “_draft”: false, “property-id”: 10398, “address-1”: “SA1 6JE”, “town”: “Swansea”, “postcode”: “SA1 6JE”, “property-location”: “Mount Pleasant”, “display-address”: “Norfolk Street, SA1”, “location-town”: “Swansea” “location-county”: “Swansea” “price-text”: “£250 Monthly”, “price-monthly”: “250”, “pre-reduction-price”: “”, “beds”: 6, “baths”: 1, “receptions”: 1, “status”: “AV_LET”, “long-description”: "Available for the 2018/2019 academic year Charles Perrett Property are delighted to present this spacious six bedroom student property for rent. The property has an open plan kitchen with large lounge and benefits from five double bedrooms and one good sized single (Don’t worry the rent is cheaper on this room!). There is also a bathroom, WC and separate shower room. Viewing comes highly recommended! ", “short-description”: "A spacious six bedroom student property for rent. The property has an open plan kitchen with large lounge and benefits from five double bedrooms and one good sized single (Don’t worry the rent is cheaper on this room!). ", “garden”: “”, “remaining-lease”: “”, “price-reduced-date”: “”, “available-from”: “01/07/2018”, “furnished”: “F”, “photo-1”: { “fileId”: “580e63fe8c9a982ac9b8b749”, “url”: “https://d1otoma47x30pg.cloudfront.net/580e63fc8c9a982ac9b8b744/580e63fe8c9a982ac9b8b749_1477338110257-image20.jpg” }, “updated-on”: “2018-09-12T08:11:14.269Z”, “updated-by”: “Person_5a95c05c41e04900018a4914”, “created-on”: “2018-09-10T11:17:50.440Z”, “created-by”: “Person_5a95c05c41e04900018a4914”, “published-on”: “”, “published-by”: “” }

help me to understand…