Streaming live at 10am (PST)

Upload JSON file "apple-app-site-association"

My website supports an app download. This app has universal links built-in and depends on a “apple-app-site-association.json” file.
Every time I upload it, I get a message about a lottie thing. I just want to upload this file and host it in the root.

Can anyone point me in the right direction?

1 Like

You can’t upload regular json files to Webflow. I am not currently aware of a workaround.

1 Like

Thanks for your answer @webdev
That’s very unfortunate. This file needs to be in the root domain. :frowning_face:
How to solve it,…

1 Like

Same issue. This is a dealbreaker for us to be able to migrate.

100% @Emin_Israfil , I now need to find an alternative! It seems sooo simple to allow. I might just downgrade to the free version. Download the HTML and host these on a static site in an S3 bucket.

So I setup a 301 redirect and that seems to actually work.
Hosting the file elsewhere, then use 301 redirect to respond to the domain.ext/apple-app-site-association

Update on this,… the 301 works.
But now I also want to use /.well-known/ folder to host important info. https://www.google.com/search?q=what+is+the+.well-known+folder

I add a 301 redirect, but this time it doesn’t work. I get a different 404 than my own site 404.
Also adding a folder .well-known results in a slug without the “.” This really frustrates me.

Why does Webflow limit all these options?? This should be a 2 minute job turning into a multi day ordeal.

1 Like

I’m having the same issue as @Naos above. I’ve tried setting up a redirect from
/.well-known/assetlinks.json to https://storage.googleapis.com/my-bucket/assetlinks.json … but when I attempt to reach it I get

<!DOCTYPE html>
<html>
  <body>
    <p>Invalid .well-known request</p>
  </body>
</html>

I’ve also tried preceding the leading dot in well-known with a percent sign in case it was some sort of regular expression/escaping problem (e.g. /%.well-known/assetlinks.json), but that doesn’t seem to work, either. Please help! :frowning:

@Naos I haven’t tried this yet, but I just noticed you can alternatively associate your domain with your app in Google Webmaster Tools… perhaps this is a workaround? https://developer.android.com/studio/write/app-link-indexing?utm_source=android-studio#associatesite

1 Like

Thanks @mdesjardins! I’ll look at it.

It’s very dissatisfying isn’t it,… you’d think at least a 301 redirect OR a folder in Webflow with a “.” should be able to be realised.

I am not able to verify domain for microsoft identity manager.

Host the file at: https://{YOUR-DOMAIN-HERE}.com/.well-known/microsoft-identity-association.json . Replace the placeholder {YOUR-DOMAIN-HERE} to match the verified domain.

With redirect url I am getting the same issue(‘Invalid .well-known request’) mentioned by @mdesjardins

Please help!

1 Like

Yes, it’s very frustrating! If you have found a solution, I’d be happy to hear it.

Good morning all! I have a similar issue @Kapil_Kumar. Any solutions in the making?

Thanks.

Ben

Maybe we should ask @thesergie directly :slight_smile: Because it seems such an easy addition.

There’s no way we can have a feature we can upload or configure apple-app-site-association and Webflow will put it under .well-known/?

Hi just want to follow up if any update?

Sadly no! I even went as far as to going on LinkedIn and finding a product owner that works for webflow to shed some light on this,… I guess it should be proposed on their feature list,… then get a lot of people to vote on it.

This is super silly that they dont support! Come on webflow, do something about this! There is some relation to this wishlist, as it is a static, and we want to choose how to load that static: Clean asset links: Host assets on a site's Custom | Webflow Wishlist

1 Like

+1 , this should be a standard feature.

1 Like