Streaming live at 10am (PST)

Uploadcare LIVE option set to True causes webflow.io site throttling


#1

I can’t modify anything on the front-end inspector in Chrome! Webflow is throttling javascript and every time I try to make a change it overrides the javascript. Please disable this!


#2

Hi @cjroe, custom javascript used in preview mode is not rendered until the site is published, that might be part of the issue you are facing, but I am not entirely sure what you are trying to edit.

Could you help to provide a screenshot of what you are trying to edit, or provide more info? Link to site, what code you are trying to edit, how Webflow is “overriding” the javascript?

Likely any custom code change made in preview is not going to work as you intend until the site is published.

Thanks in advance


#3

It’s not in preview, it’s on the staging domain .weblow.io. When I open up Chrome inspector CMD+Option+I, it doesn’t allow me to modify the styles because there is javascript running continuously on the page and something is setting the styles on a loop or something.


#4

Hi @cjroe, could you help to share a link to the site and what code you are trying to edit? If you want to send me a private message with the details, I can take a look.

Thanks in advance.


#5

Go to that page and try to modify some styles in the inspector panel…

Notice the DOM is being throttled by modifications on the <html> element.

02


#6

Hi @cjroe, thanks for the link, that really helps. I have been looking at the site, and I have seemed to narrow the issue down to the uploadcare custom code that is being used in the Body.

When I tested the site with the upload care custom code, I can observe the issue you reported. As soon as I remove the uploadcare custom code, then it starts to work as expected, see here:

I would check that custom code first, it looks like it is causing that throttling.

I hope this helps, let me know if you experience something different after removing the upload care custom code (as a test on your side).

Thanks in advance.


#7

Great, thanks I will take a look and confirm the fix.


#8

It turns out that Upload care indeed has a live setting:

Set the UPLOADCARE_LIVE option to false.


#9

Hi @cjroe, that is awesome, great that you found that solution, thanks for sharing that, you rock :slight_smile:


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.