Streaming live at 10am (PST)

URL appears wrong whenever i search in any search engine


#1

Hello,
My site is http://nightclubslondon.com but when I do a search on any search engine like google duckduckgo or bing this is what comes up:


which redirect to a wrong page which is not listed in the sitemap.
Is there any solution?
Thanks in advance :slightly_smiling_face:


#2

Hi @micky_mickey (so good you have to say it twice :grin:) and welcome to the Webflow community!

Disclaimer: I’m not an expert in SEO by any means, so someone can probably give a more in-depth answer to this, but that URL you show does exist on your site even if it’s not in the sitemap.

Search engines tend to show links to content that they feel is best relevant to what the user is looking for. So in this case, there could be a mix of tags, alt text that combined with the search query is throwing up that page.

Try searching for your site as though a user would, and use the Google Search Console to monitor the links that are being clicked. If that page is consistently being shown and you don’t want it to, then you could always add a redirect on your Webflow settings, but bear in mind that the page won’t be able to be viewed any longer.

As you add new content, add your sitemap to Google and things change. I’ve had sites where I’ve not ranked at all for a particular blog post, then after a week I’m on the top spot.

One thing is for sure, the search engines will keep showing what they think is relevant, so if you typed “night clubs london” then the tags on that page may be what’s triggering that page.

You can always add a no-follow tag to the site code for that page too to make sure it’s not shown.

Hope that helps even a little?!


#3

Thanks, its helped a lot :slightly_smiling_face: