Streaming live at 10am (PST)

URL is not on Google

Hello, I’m having problems with google search.

image

I’ve set up SEO

Webflow Subdomain Indexing is disable now (it was enabled)

This is the robot.txt
User-agent: *
Disallow: /Work/
Disallow: /Blog
Disallow: /Team
Disallow: /Password
Sitemap: https://www.sprintertowing.ca/sitemap.xml

Auto-generate Sitemap YES

Google Site Verification YES

I tried many times to request indexing but nothing change (maybe the subdomain configuration on enable was the problem?)

image

Hello @Hector_Gastaminza do you have a link to your site. Wellcome to the Forum. To me it looks like you have a domain problem, did you get your domain from google? if you did you should contact them, or contact whoever you got your domain from. Or, if you don’t get any help here, try the webflow support team. Good luck.

Hello Pablo! Thanks for your help.

Our site is www.sprintertowing.ca we have this domain in godaddy since at least 2 years ago.

I can reach the site, I can use google search console test live.

In order to learn, why did you suppose it is a domain problem?

Regards

Hello @Hector_Gastaminza,

I initially thought your whole site was not working, not just a url, since you didn’t have a link for your site. So for the problem that you have, is it on a new recently created page? if it is, then maybe create the sitemap again on webflow authenticate it with google again and try to search for it again? It looks like you did the right steps for SEO on webflow. Check on your google search console what seems to be the problem and then pass it along to the support team at webflow, they will surely have an answer for you. Good Luck.

Google begs to differ.
CloudApp

1 Like

Hi. Thanks for your help.

Using your tip I could get the same result, but then, why google console search show this:

and trying to search the website organically using the keywords I’ve using in the SEO, I could not find it, I don’t know if it is because my website couldn’t be worst or there are other problems not directly related with the content.

Click “req indexing”

Hi. Thanks for your help.

I’ve tried many times to request indexing. But it did not work.

What page url was not in the index? It was not shown in your screenshot.

1 Like

Could be this problem related with redirect?

I’ve started my proyect as a free developer, using a webflow free domain to publish my site and see how it looks while I was learning a little more about webflow because I’ve never used it before.

When I’ve got something decent enough I pay a webflow plan and I moved the site to my custom goDaddy domain. Besides I’ve changed the webflow subdomain as well (without a strong reason as I didn’t like the name I’ve used before).

I’ve rollback to the ugly subdomain name I’ve used before in order to see if the problem is related to that without success.

I don’t have any redirect set in my set, but as far as I believe, I should add the webflow subdomain aren’t they?

The site history is:

Hi, it is not on google, the first screen shot I’ve uploaded show that.

If you want to rank your website you’re going to want to focus on your custom domain. You also need to do it right from the beginning, or you can end up wasting lots of time.

It’s impossible to teach SEO in a forum topic. I think it is better for you in the long run, if you invest some time learning the basics. I recommend using this Google site as your starting point.

https://www.google.com/webmasters/

We can help you with specifics related to Webflow, when they come up.

1 Like

Thanks for your help, as you see I’m not an experienced person doing this so at this point I cannot understand what is happening here.

Why the URL is not in google?

I agree I cannot pretend to be the first organic site shown at this point but that sentence is like it directly is not in google, and as far as I tried to find it using the keywords I’ve used in the webflow SEO it is like in that way, I could not reach page 10 or farther without find nothing about the site, for that reason I was thinking about a configuration problem.

So you’re saying everything is ok with the configuration and the problem is the content and the SEO strategy isn’t it?

Show me the actual URL you say is not on Google that should be.

Your custom domain is indexed. So are the other pages I showed you in the screenshot.

CloudApp

Ranking is something completely different. There is no obligation for Google to rank your site. If you want to rank, you will need to build up your ranking factors.

Hi, thanks for this hard task to help me lol

I’m not saying It is not, but it is very confusing then

What is this mean?
https://forum.webflow.com/uploads/short-url/bRh6earXbWatcoQNiTbcPr3VRBZ.png

Thats a great question for Google. Right hand versus Left Hand? Data Centers not in sync. US shows home page, CA does not. Give it time. Google works on its time not yours.

Here is google.ca searched.

CloudApp

Thanks all of you for your patience, for me it is a bit confusing and I’m worried to not be indexed for some configuration problem, I will read the information you gave.

I will have some patience with google as well an see if I could improve the ranking.

I had a similar problem with one of our websites (Indexing Sitemap in Google Search Console). It seems like somthing is wrong with the sitemap.xml. You can try to (1) overwrite the robots.txt setting with XXXX and re-index the sitemap in the google search console. (2) set up the robots.txt with the parameters you like and again re-index the sitemap in the google search console. I think this would do the trick.

Thank you PhilippX,

I will have to do something because this problem is not solved

I know I have to learn a lot about SEO, google and other stuff, but it seems there is something else is wrong. As far as I understand google is excluding everything. I’ve waiting as many here suggested but nothing good it is happening.

It says no sitemap but in the sitemap tab it says is ok

Could it be related with some problem between my custom domain and the webflow subdomain?

I will check my robot.txt, and the tutorials about that configuration.

Is there anything wrong in here?

Thanks