Streaming live at 10am (PST)

Use Latitude, Longitude in Maps Settings


#1

If i put Lat,long coordinates directly on the Map Settings it translate to an Street address and then on published site it get at wrong place (about 100 meters wrong).

Webflow translate coordinates to street address an then translate the street addres back on coordinates, that cause de problem.

Actually i use this workaround:

  1. Create a map and set it hidden.

  2. Insert a embed html using the correct latitude logitude.

< div data-widget-latlng="-##.######, -##.######" data-widget-style=“hybrid” data-widget-zoom=“16” data-widget-tooltip=“My Address” class=“w-widget w-widget-map” >< /div>

I suggest the map settings detect if you put a coordinate and keep the value as is. Or is there other way i do not know?

Thanks in advance.


#2

Hi @Alan_Schwertner thanks for posting about this.

Thanks for posting this, this definitely sounds like odd behavior.

I wasn’t able to reproduce this. When I pasted lat, long coordinates into the settings it loaded the correct location in the Designer and on the live site.

What sites are you seeing this issue occur in? When did it start occurring? Can you send me the site Read-Only links please?

Please send me screenshots of the behavior you’re describing.

Can you please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off: https://support.google.com/chrome/answer/95464?hl=en
(2) If the problem persists, please take a screenshot of your Console and send it to me: https://developer.chrome.com/devtools/docs/console

Could you please let me know what browser version you’re using by sending me your information from this page?

There should be a small share link when you visit the page which you can send to me.

Thanks in advance!


#3

HI @Alan_Schwertner

Thanks again for posting. I spoke with our team more on how we handle lat/long input.

This is what is happening when you use lat/long: the geocode API that we use is returning the nearest address for those coordinates.

In some cases, these coordinates are a point that may not translate to an exact address based on these geocode API responses. So the location shown on the map is the closest address to that point rather than the exact location.

In this case, your custom workaround is the best way to keep the pin in that exact location.

I hope this helps to clarify!


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.