Streaming live at 10am (PST)

User-scalable="no" doesn't work

Hi,

I found this post here on the forum after someone pointed out to me that I have the code in, but the mobile page still zooms.

I have integrated this code in the custom code section in the footer:

.

Can someone tell me what is wrong here. I have tested on Safari and Chrome > iPhone.

Thank you.

Best regards
Toby

Preview link:

Here is the live website:

First, the meta name=“viewport” tag is always placed in the head (as are all meta tags) and I suspect browsers are coded to look for it there on load. Second, Webflow loads it there auto magically and does not let you override it. Third, it is a really bad practice to try to disable a feature (zooming) that is depended upon by many people. If you don’t like the way your layout looks when zoomed is no reason to try to take away a feature that is designed for people with visual disabilities. I use reading glasses for example and when they are not present pinch to zoom is the only way for me to read sites with 12px fonts on my phones screen.

It may be possible to load that additional meta tag in the head (not the footer) and influence some (not all ) browsers since some browsers will ignore the user-scalable value. You can try it but I can’t think of a reason why this is a good idea myself. Cheers.

Hi Jeff,

thank you for your message. Previously I had the whole thing in the Head as well. Since it didn’t work there either, I moved it down to the Footer on the recommendation of the post here on the forum. It also seemed more logical to me that it go in the header.

To the zoom itself: I don’t need that either and would leave the scaling in if it were up to me. But Google and some tools and SEO experts think it’s better to disable it for a clean mobile solution.

I can’t understand that either, but unfortunately that’s the way it is. I’m also thinking about older people :wink: No, fun. I also like to zoom in when I can’t read something properly.

Maybe I just leave the shit. Still, it bugs me that it doesn’t work when I integrate it here in Webflow.

Best regards
Toby

@Toby-

I would like to see the references if you cared to share (Google).

When you build responsive sites this should not be an issue. I suggest reading:

Safari implemented / Apple created the tag when responsive was not a thing.

Hope this helps.

The reason some people would like to disable zoom is because webflow gives them an error when you zoom on iphone, like on my case.

I tried to find a solution here in the forum and also all over the internet and there is none. I never had this problem before when I build my websites from scratch, but when using webflow I had many problems, I was able to fix most of them BUT this one I haven’t be able to find a solution. This happens only on iphone when you try to pinch-zoom the page will reload and when you do it again you will get an error saying: “A problem repeatedly occurred on…”

I wish someone here can help me fix this problem, or at least help me disable the zoom without questioning our decision, we know if you disable zoom is not good for some visitors, but at least is better than having a black screen telling us that the website has an error. That alone will make you lose credibility more so than not been able to use zoom.

If you need help resolving an issue you need to at least share a URL where the issue can be viewed. If you do I will look.

Hi Jeff,

I think I can close this task. I went with the thoughts of your answers above. Actually, I agree that a user should be able to zoom on the phone as well, so they can see something better if they want to.

Thanks to you for following up.

Toby

I meant to reply to @Carlos2021 but glad your issue is resolved. Thanks.

Yes. I saw that after i send my Feedback. :slight_smile:

Ok thanks, here is the link of the page I’m working on:

https://www.traveldiscounters.us/Kenya-Nairobi-Nakuru-Maasai-Mara-Safari-Tour.php

This is happening in all the pages of this website btw.

Thanks in advance, I appreciate any help.