Streaming live at 10am (PST)

UTF-8 Encoding Issue on Export


#1

Hi,

I have a problem with UTF-8 coding. I have a server that is outside my country. Is it possible that it causes the problem? All is working fine in the server that is in my country.
Any idea for solution?
Can I force Webflow to create html with iso-8859-2 insted of UTF-8 ? Iso-8859-2 seems to work fine on the server that has problems with UTF-8.

Page published on my server outside my country: http://www.ilpatio.pl/nowa/index.html
Page published on my server in my country: http://www.punt.pl/wedel/index.html

Language setting is set correctly to "pl".

I would be grateful for asistance.

Browsers I use:
Chrome 41.0.2272.89 m
Opera/9.80 (Windows NT 5.1) Presto/2.12.388 Version/12.17
Firefox 36.0.1

Cheers
Marcin


#2

Hi @wed, thanks for the post, I am running some tests now. I am setting this to bug status for the moment until I finish my testing. Cheers, Dave


#3

Thanks Dave.
Just for your info. If I open exported html file in notepad, save as UTF-8 format and upload to server, it works fine even on the server outside my country. It seems like created html files have only meta tag UTF-8 inside the txt file but are not coded properly as UTF-8 (with Polish language).
Just read about coding, UTF-8 stays the only reasonable solution for creating my sites frowning

Cheers,
Marcin


#4

Dave I just made another test. I used Programmer's Notepad and checked encoding of exported html files.
They are encoded with UTF-8 no BOM. Saving as UTF-8 (with BOM) almost does the job. After uploading to server all works almost fine apart from the type of font. UTF-8 encoded letters starts to show, but type of font is changed.
Here you can see it: http://www.punt.pl/wedel/utf-8withBOM.jpg
Please check if html generator can save files to UTF-8 with BOM.

Cheers,
Marcin


#5

Here you have a comparison. Looks like BOM really makes the job.

Cheers,
Marcin


#6

Thanks for the additional update @wed. As soon as I have an update regarding this, I will notify. Cheers, Dave


#7