Streaming live at 10am (PST)

Validating domains with Cloudflare and SSL failing


#1

Hi, I have some strange results when I moved my DNS to Cloudflare. I uses to have a https here and that's what I wanted. Trying to validate the domain records kept failing and after adding de cname webflow proxy's the redirect seemed to work, but still no validation of the domain in the webflow backend, it keeps saying unlinked.

Next strange event is de https, when you go to www.digitalninjas.io it successfully redirects to the https version. If you visit digitalninjas.io it redirects to www.digitalninjas.io but nog the secure version. Any thoughts? I added the cloudflare DNS settings below. The SSL setting is set to flexible.

I'm not sure if the not being able to validate the domains is cause of the problem.

So two problems:

  1. I can't validate the domains, adding the IP as a-record didn't seem to work and I have read a flattened CNAME would work as well.
  2. The redirect from www.digitalninjas.io to https://www.digitalninjas.io works. But from digitalninjas.io it just redirects to www.digitalninjas.io (insecure)


#2

Update: I have disabled all certificates and ssl, I have placed the two a-records told by Webflow, I will let it rest for a time now and see if those changes will be picked up when I try to activate them.


#3

Okay so i waited 16h now and there is still no change. I have set Cloudflare's SSL to off, disabled SSL on Webflow and added both A-records to the listing, still not being able to confirm that it is working. The Cloudflare nameservice is set up properly since the cname records for Gsuite are working.

Any suggestions?



#4

It does not look like the DNS records have been saved properly. Doing a DNS lookup here returns no results for your domain:

I'd recommend contacting Cloudflare for help.


#5

That is correct since I haven't set up a www cname, only the root domains yet, I will try to fix that first then.


#6

SOLUTION

If you have problems validating the domain records you have to to the following stuff:

  1. Click on the orange cloud of cloudflare after the a-records and www cname to disable http-proxy ans use dns-only
  2. If using SSL, make sure you set the crypto ssl setting to full since Webflow is providing a certificate.
  3. Validate the domains in Webflow under hosting

Most important is to disable the Cloudflare's http-proxy for both a-records and the provided cname, if you don't do this Webflow won't be able to see it's correctly configured.


#7

@Daan_Kauwenberg another option you could take if you utilize the Webflow SSL service (where we provision your SSL Certificate for you automatically) with Cloudflare as your DNS provider, you can actually use their CNAME flattening feature (serving up your root domain over SSL, allowing you to set your root domain as the default domain with Webflow SSL hosting).

The only records you need to point your custom domain to your Webflow hosted site with Cloudflare as your DNS provider are two CNAMES pointing to proxy-ssl.webflow.com, as shown in this screenshot:

Be sure to set your Cloudflare settings to DNS only (so click on the orange clouds so that they're grey and say "DNS Only"):

With this set up described above in Cloudflare you wouldn't need any A Records on your root domain as they are no longer necessary with the CNAME record pointing to your root domain.

Also if you have any subdomains you just add a CNAME for those pointing to proxy-ssl.webflow.com


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.