Streaming live at 10am (PST)

Very slow loading of Webflow site


#1

Hi all,

I wondered if anyone else has been having a similar issue…

We have noticed that over the past few days our website has slowed down considerably on the initial retrieval of a webpage.

So basically, I have identified that the slowness is happening before the assets are even getting to the point of downloading. When a page is requested, it hangs for a minimum of 5 seconds and then kicks in and starts downloading the HTML and all of the assets.

It doesn’t even seem to matter if you’ve been to the page before and seems to be every 4th to 6th page it hangs.

The above all seems to point to the CDN that Webflow uses not being quick enough to grab a fresh copy of a web page?

Just to clarify, I have sent a support ticket to Webflow, this is more curiosity if anyone else is noticing this issue?


#2

Is this happening everytime you load the site, or ony the first time? I have a very slow load of each page immediately after a new ublish, but once they’ve all loaded, anywhere, they’re served fast to all other clients. Can you test that?

Edit: what I described most likely happen on pages with CMS content, not purely static pages.


#3

Hi Vincent.

I have tested this and whilst publishing does cause what you have suggested, it’s not related in my specific case.

90% of our website are static pages and only seems to be very sporadic. Sometimes you can go from page to page with lightning speed and then all of a sudden, the issue occurs and it hangs for about 5 seconds before loading the page.


#4

Can you share the url?


#5

Absolutely, it’s https://www.telecomsworldplc.co.uk/


#6

All the pages?

Home loaded instantly here. All the pages loaded instantly almost. Apart from pages from Case studies, they must be CMS, initial load was a few seconds (4ish) but once loaded, they loaded fast in another browser (without the same cache)


#7

Everything loaded instantly for me.

Except… the pages under About Us -> Innovation Lab.

All the pages in that section did take a more time to load.


#8

Hi Vincent/Revolution,

Thank you for taking the time to look over the issue yourselves. It’s definitely sporadic and not always consistent.

I definitely know about the case-studies/about-us areas. You are right they are CMS driven so will take a little time initially to load.

Yesterday the rest of the site was hanging every few pages. This morning it was every 5th to 6th page… (non CMS). It just happened again clicking through the number pages on the inbound nav.

Out of curiosity, where are you both based? I’m in London so could be a datacenter specific issue?


#9

I’m on the french west coast and I tested on both VDSL and fiber (no difference so I didn’t mention it)


#10

Ah okay. In that case, I feel confident to close this as a non issue and go back to the shareholders that they are probably finding the slowness happening on rarely accessed pages. Pages that have AdWords linking to them are loading instantly.

I really appreciate you taking the time out to test this yourself and let me know your findings.


#11

atlanta / georgia / usa here


#12

I’m from the Netherlands and must say i am experiencing slow websites on all Webflow sites we’ve build. They are all 3-4 times slower than about a month or 2 ago. I’m going to address this in a separate topic as well, because load times are (now) way too high for comfortable site-surfing and i’m very curious about what is going on.


#13

This topic was automatically closed after 60 days. New replies are no longer allowed.