Streaming live at 10am (PST)

Very slow loading

Hello,

I have finally finished my first website on webflow.
I am no developer and I have a very hard time fixing the loading speed.

I have 5 seconds until the Largest Contentful Paint!
The full report is here.
I (think I) optimized the images to the best possible without WebP…

I don’t understand this very long time to the page showing…
Also, I set up my domain exactly as suggested by Webflow.

I would really appreciate your help as I promised my partners I could launch the website. :sweat_smile:

I look forward to your answer.
Joachim


Here is my site Read-Only link.

Hello,

I have investigated and asked for help on the Facebook Group here.
A few developers helped me out but no one can figure out why this is happening.

It does not come from my DNS because the upcrown.webflow.io site loads as badly as my live site.

I hope the support team can help out.
Joachim

Two things you could work on. Typekit fonts which account for some of the delay and looks like recaptcha is enabled on the project since it is being loaded site wide. That one alone is 750ms in my quick test.

Hi!

Actually I now score A on GTMetrix.
It was because I had setup Google Optimize in the settings.
That was more than 3 seconds of charging time.
Webflow support solved it quickly and efficiently!

I will keep your comment in mind to optimize further!
Thanks a lot for taking the time to check

I do need the typekit thing if I want to load adobe devanagari font right? :thinking: