Streaming live at 10am (PST)

Vimeo/YouTube videos not working on the latest version of Chrome?

https://www.tonyholz.com/88nine

Hi, does anyone have the most updated version of Google Chrome?
I’ve noticed that the embeded Vimeo video in the link above (↑) no longer displays correctly on the newest browser version…It works just fine on safari though.

Any ideas/solutions?

Thanks~~

Works for me in newest chrome

1 Like

Hi @Tony_Holz

Thanks for posting – this is definitely strange behavior. This is a bug that was rolled out along with Chrome v69. You can view the report here:

https://bugs.chromium.org/p/chromium/issues/detail?id=880669

Our team is working hard to find workarounds this Chrome issue, but I don’t have an exact timeframe as to when a fix will be live.

I’ll definitely keep you updated as we make progress with the workaround, or if Chrome pushes a fix.

​Thanks in advance for your patience.

3 Likes

Hi,
I have some videos on this website and It happens to me, I reported to Webflow support, I get some responses with some suggestions how to fixed, but still not working. Just waiting for a solution. Here is the website:
https://www.hablandoingles.com

HI @abel01

It looks like Google rolled out fixes for this. It may be a separate issue that you’re encountering though. Our support team will respond back to your email as soon as possible.

Thanks for your patience!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.