Streaming live at 10am (PST)

Webflow adding http:// to the link - How to override using the Back Tick character


#1

Hi guys!

I have an issue here with adding various links to the objects. My goal is to add some icons to the web-page and make them call different links.

First, I couldn’t find link option for the canvas object. Maybe I look in wrong direction, maybe it’s impossible (which is weird). However, I found the link container and put my icon there. Now link can be assign. And the first question is why so complicated? Why here is no link option for canvas object? Why do you need to add one extra container?

Second, I can’t add link to call application from mobile browser. You know if you wish to create an email button, just add link "mailto:123@123.com", if you want to call by phone, just add “tel:1234567890”. As I can see link container is providing this kind of ability. But now tricky goal (actually, it’s tricky only here) - I need to add link calling mobile phone applications like Skype, WhatsApp and any others. And… I can’t.

When I use link field and type there “skype:aleksey-msk” and then hit enter I see “http://skype:aleksey-msk” which is dead link. Same situation with WhatsApp. Webflow is adding “http://” to my link “whatsapp:/send?phone=1234567890&text=Hi” which is making this link dead too.

When I ask support for this case the answer was it was made to avoid typo when user forget to add Http:// to his link and then this link is calling local resource instead of external. Okey, maybe it is kind of solution, but since then all other people unable to use all various of other links, like in examples above with application links.

They are kindly provided me with solution for Skype (you can embed the code from the Skype web site - of course if you are using PRO plan). And I found web link to send WhatsApp messages via web API. But there are a lot of other cases with other applications. Someone decide to call map like map:coordinate, someone create contact contact:new or call some kind of special phone-player to play media. All of this cases have in common one template AplicationName:Command and there is no http:// allows.

So, I’m asking to step back in link development and allow people to use links they need without automatically adding http://. And I hope developers will not add another tab in link options like “App” because there can be numerous of other cases we don’t know now and it’s better to use one versatile solution rather than many extra options.

What do you think?


#2

Hey @Alexey_Borisov,

Have a read @vincent article on inb4.

Should help :wink:


#3

The simple question is - why do you need tricks to set link? ))


#4

i have no idea @Alexey_Borisov since i am not working for Webflow.
I’m just here to help.
Did it worked for you ?


#5

You need to type a backtick before your link but not press Enter, rahter click anywhere else to leave. Backtick is a direct key on your keyboard.

*edited to add a bit of gymnastic :wink:


#6

Hi @Alexey_Borisov, @vincent and @zbrah, I did some more checking and clarification on this with @bart, and the back tick is still working, however if you put in the back tick and then a value and press enter, the back tick will be replaced with http://.

If you add the back tick character and then just click outside of the url field, the custom value will be saved.

I hope this helps!


Click on phone number to facetime?
#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.