Streaming live at 10am (PST)

Webflow Badge with Wordpress Plugin

Hey Everyone,

I’m new to the Forum but have been using Webflow for a few months now and am loving it.
I recently worked on a project where we need to use the Wordpress plugin to serve up some webflow pages to the site. Everything works great except the “made in webflow” badge still shows up. Let me address some of the initial questions that will arrive:

  1. We have the CMS Site Hosting plan
  2. The “show badge” option has been turned off
  3. The cache has been cleared
  4. The site has been published recently

Any thoughts? The plugin page states that this can be removed:

Thankful for your help!

Hi @ShaneV, thanks for your post.

To remove the badge, there are a few steps needed.

  1. Create a cname record for a domain like connect.mysite.com, where mysite.com is the domain you manage pointing to your external hosting server, and point the connect.mysite.com subdomain at proxy-ssl.webflow.com.

  2. Add the connect.mysite.com domain to the list of custom domains on the hosting tab of project settings

  3. In your wordpress pages plugin setup, the url you will use to access your site will be https://connect.mysite.com instead of the webflow.io domain.

When using the webflow.io domain the badge will show, but if using the custom subdomain added to the hosting tab in Webflow project settings and then publishing the site, will remove the badge.

I hope this helps

Thanks for the help @cyberdave!!

I’m working on implementing this right now but it may take a day or two as I’m having to wait for our IT Department to create the sub-domain. I will make sure to confirm that it works when we’re done!

Is there a reason why Webflow keeps badge on the Webflow staging URL? It doesn’t show up normally (if you visit the webflow.io domain directly) so it would make sense that this also be true for pages implemented through the WP Plugin.

I suppose Webflow is trying to maintain some sort of brand “stamp” when using the webflow.io URL. Maybe since “webflow” is no longer visible in the URL, they opt for adding the badge?

In either case, I really appreciate the help!