Streaming live at 10am (PST)

Webflow cms is freezing

I’m trying to upload new pictures inside each blog-post(collection) which involves the following steps:

  1. opening up an item of the collection -> 2) upload a picture in custom image field -> 3) save -> 4) opening up another item of the collection and repeating the same steps again.

I tried to do that from both designer and editor views, but it is taking unexpected time, i.e. around 1.5 mins to upload one picture and go back to a new blog post and do the same actions, also the screen freezes quite a lot of time and then have to refresh the screen again, this is quite frustrating and is taking a lot of time to do one simple task. Tried on incognito too, but no success. Only one webflow window was open at that time with some other sites open in around 6 different tabs.
Please let me know what can be done in this case, have been facing this issue for almost a week.

Picture size: ~100kb - 500kb
Paid Plan: Site plan (CMS), Account Plan (Free)
Browser version: Google Chrome (Version 79.0.3945.79)
Internet speed: ~10mbps


Here is my site Read-Only: https://preview.webflow.com/preview/fyle-blog?utm_medium=preview_link&utm_source=dashboard&utm_content=fyle-blog&preview=f781aa3c881314261ee7231b1d7a631f&mode=preview

Hi there :smiley:

Thank you so much for reaching out to the forums.

I am not able to reproduce this on my end, but I do see the odd experience when I preview your site. Would it be possible to do a site publish in order to be fully updated and then see if this issue still persists?

Also, do you experience this error after restoring to a previously saved backup from a day or two ago?

Let me know if any of this helps or not, I’m here to continue assisting through this if we need to explore other workarounds.


​My best,
​Riley

Hey RileyJones,

Thanks for replying. We do keep publishing our site regularly at https://fyle-blog.webflow.io/.
And if i restore the previously stored version from 4 days back, i’m still facing the same issue. Is it something to do with the collection size? As i have more than 150+ items in one of my collection which i have been using it everywhere, also the screen sometimes just freezes while searching for the item in my collection, or just when scrolling those items. Please can you have a look at it. Thanks.