Streaming live at 10am (PST)

Webflow Design running EXTREMELY slow now


#1

Webflow Designer running EXTREMELY slow now.

Taking upwards of 5 seconds to respond to element clicks in Design Mode.

Does not appear to be happening in Preview Mode.

This is after a full system restart. Initial load of Webflow in new tab.


Webflow Designer Lagging
#2

Same here. I am having the same issue.


#3

There is no solution for this … I think the webflow is getting too heavy for chrome.

I am working for several months in slow motion …


#4

Thanks for posting about this @Revolution @kbowman @lucaspchara

Can you please share examples of sites that are experiencing this slow performance? Read-Only links would be perfect.

Can you also share the specs of your machines and browser versions you experience the slow speeds?

​Thanks in advance, and I’m standing by for your reply.


#5

I’m having the same issue! Do you know when this issue will be addressed? I’m so close to finishing my website design but it’s now taking HOURS longer to finish.

My designer starts out working fast but within a couple hours (mid-morning usually) it slows WAY down to the point it’s taking 10+ seconds to perform a single task, even one as easy as changing font size. It’s getting worse too.

here’s my link in case you need it: https://preview.webflow.com/preview/signaturesprings?preview=e0c0bb1d0364e5f3aeaed13b8441d996


#6

just fyi
when I opened your preview… I saw this…

(Path not found:) not sure if it means anything

41 PM


#7

I have no idea what that is, never seen it before. I think that’s a Webflow error?


#8

yes… I’m guessing you use the CMS


#9

i’ve seen that same error when viewing webflow templates.


#10

Nope I don’t use CMS… Well actually I created a collection but it’s not published anywhere. The items in the collection are all in draft status.


#11

@Kim_Rickards ok - so maybe it’s the collection that’s creating the error message
or as @dapitts08 said… maybe it’s a template issue.

Are you using a Template site ? or is it your own design ?


#12

I have been talking about lag des 2015 and nothing was solved (Slowness / lag on windows 7), when I see the memory consumption of my site, it arrives at 2gb of ram and there it is impossible …

My computer:

Internet 10mb
Windows 10
Chrome 62.0.3202.94
i7 2.20ghz
8GB ram
SSD

Sites with lag:
https://preview.webflow.com/preview/d2c-ui-kit?preview=a760935886d66821504c6488e69728c3

I can record a lag video, currently the largest lag is when I create class and at the moment of opening an animation (animation 2.0)…

I’ve already got in touch with the support and I’ve spent all this data …

I’ve been talking to the programmer of my company and he says that the chrome was not made to run a program of this size, there will not be a miracle …
further why the site I’m working on this very large, there is a lot of information at the same time … already resigned myself …
I’ll wait for Webflow to get even heavier (this 2.0 animation is helping), so who knows when everyone gets lag the webflow starts thinking about making a computer program … which will take a long time to develop I imagine. …


#13

@Revolution I created the site from scratch, no template used. I’ve been working on it for months with no issue until very recently so it makes me think the issue is with Webflow’s platform, not my actual site. Especially since so many others are having this issue lately too.


#14

I stopped working in chrome months ago and moved to safari to work on my websites. You mac users should try the same. Working in Chrome when its that slow just isn’t bearable. Safari seems to be able to handle a heavy application like Webflow a lot better.


#15

I’ve seen slowness in chrome too. when that happens, if I completely close all tabs and restart chrome it is fast again… there definitely is some kind of bug. I’ve had good success with using a browser called vivaldi https://vivaldi.com/download/?lang=en_US which is based on chrome but much much faster. I’d also be interested in trying with the new firefox browser quantum if it were supported…


#16

I tend to have many - many - tabs open at anytime.

To solve some Chrome memory issues…

I started using “The Great Suspender” extension

It’s helps a lot.

At minimum… it reduces Chromes memory footprint
as it “suspends tabs” that are not used in a certain period of time.

This doesn’t alleviate Webflow bugs… but it does help with memory consumption.


#17

I have been on the forum talking about unusable designer last month but kinda got the feeling from webflow it was my fault, yet I keep getting slow designer even with new projects with nothing even loaded on the page :no_mouth:


#18

The designer in Chrome is definitely unstable at the moment.

I use Webflow for 8-10 hours a day so generally notice most nuances, no matter how small.

I am seeing the inability to undo (at certain times), severe lag when switching to live preview and sometimes not able to at all, having to-reload the whole page at regular intervals after freezing and it loses connection quite a lot recently.

One particular site I developed that is very CMS heavy lags to almost unusable levels at times. I have 250mb broadband so I know it’s not that!

I tried to use Safari but that came with it’s own particular bugs so switched back to Chrome.

Used to be rock solid but is starting to wobble a bit recently.


#19

@Golden28

same here. I use it all day. Everyday. I tend to notice even the tiny changes.


I like Webflow… I really do. I think most people here like it

  • but right now… I’m a bit upset with them now.

I was doing a product demo yesterday

  • when everything simply went haywire.

The system was extremely slow to respond. The gradient tool totally screwed up.

In front of the client. Some clients are easy to deal with… others not so much.

This client is hell on wheels.

Luckily… I had an older copy of the application on one of my servers

  • but it was still very embarrassing.

So… guess I’m a little more than upset with Webflow at this point.

A lot of people count on Webflow to make money. I know I do.

Perhaps… instead of introducing new features

  • they should strengthen their core application.

I don’t use their CMS

  • to expensive
  • not enough features… I just make my own CRUD systems.

#20

Oh, man. Haven’t used Safari in years. Switched over. Much smoother. Wow. My productivity just skyrocketed.

High Sierra iMac 27 late 2015
3.2 Ghz Inte Core i5
32 GB