Streaming live at 10am (PST)

Webflow extremely CPU heavy (Chrome crashes, Safari also giving warnings))

Hi,

I’m working on a prototype of a design in Webflow. It’s currently so CPU heavy that things like dragging elements in the layer list becomes difficult. Also when duplicating an element, it takes 2 to 3 seconds to show sometimes.

I have the feeling it gets worse after working for a couple of hours.

Chrome tab crashed a couple times this week because of this. Tried Safari instead. Also Safari is telling me the current tab is using significant power, so switched back to chrome.

The design is confidential, so before I share it publicly I’d like to ask if there’s a private way of sharing this website.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Kindly bumping this message up in the hopes for a reply from Webflow :slight_smile:

Hey,
I had this same issue. But when I looked into it the McAfee - Real time scanning has to be turned off. If you have an Internet Security suite, then find your “Exclusion List”. My was in real time. It was super slow until I did this. And I turned off all the browser extensions that I don’t use much :slight_smile:

If you haven’t resolved it, let me and I’ll help you.

1 Like

FYI: You can share a read-only link via a private message, then once viewed reset it. Obviously that would grant the user you shared it with access, which could be shared via a link by them.

1 Like

Hi! I don’t have any real time scanning on my mac. I have no issues running any app, website or other webflow project on my computer. This is by far the most complex website I made with Webflow (using collection, grid, custom javascript, etc) so I think it has to do with this specific project.

Oh so it’s the first time this has happened? You’ve completed other projects with this lagging. Hmm. Oh oh, I do remember getting this after the cache fills. Maybe try after a while, simply saving and

  1. Hard refresh the browser (Ctrl/Cmd + click arrow)
  2. Clear browsing cache from Chrome settings, close browser and reopen project

I do remember doing this and it worked, after a long time in that ‘session’. It is a database on the back-end. And DB’s will use memory in a long session.

I hope you can get working better.

It happens in every browser. Clearing cache from the browser or flushing my RAM doesn’t make a difference unfortunately.

Is this a heavy image based design? If it is; remember that the designer loads the images placed on the canvas at full resolution. That can quickly become an issue with lots of images.

If not, open a ticket with support since you are not sharing the RO link.

Hey @ferry

I was having the problems here and something that really helped was installing the Clean My Mac app.

One of the options that the app offers is to unistall FOR REAL some programs and to clean up the memory when your computer starts to slow down.